1

I am moving my local Magento installation (on OSX) to the a new server (opensuse 11.4).

  • I moved the whole folder with Magento (Version 1.8.1.0 with the mt_colinus theme installed), deleted the var/cache and var/log folder.

  • I exported my local db via phpMyAdmin and imported it via phpMyAdmin on the server.

  • I modified the app/atc/local.xml file with the new server mysql data.

However I get a blank page going to the frontend index.php page.

The backend index.php/admin login page seems to be fine but after submitting the login data I got another blank page index.php/admin/dashboard/index/key/.

After enabling:

ini_set(’display_errors’, 1); 
ini_set(‘memory_limit’, ’256M’);

I got this error in the frontend page:

Fatal error: Call to a member function getId() on a non-object in /srv/www/htdocs/XXXXXXXXXX/app/code/core/Mage/Cms/Helper/Page.php on line 67

And this one in the backend dashboard page:

Fatal error: Call to a member function addCreateAtPeriodFilter() on a non-object in /srv/www/htdocs/XXXXXXXXXX/app/code/core/Mage/Adminhtml/Block/Dashboard/Totals.php on line 53

I also uploaded a blank Magento 1.8.1.0 folder without setting the local.xml file with the db info (hoping to see the installation wizard) and I still get a blank page. The error in this case is:

Fatal error: Call to a member function rewrite() on a non-object in /srv/www/htdocs/magento/app/code/core/Mage/Core/Controller/Varien/Front.php on line 165

What can I additionally try to do to solve the this issue?

closed as off-topic by David Manners, Marius, mbalparda, Keyul Shah, Fabian Blechschmidt Jul 28 '14 at 9:56

  • This question does not appear to be about the Magento e-Commerce platform within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Check permissions on the var directory. Also, I've seen errors similar to those when Magento cannot connect to the database. Check that your DB user has the correct privileges or temporarily change it to root to rule that out. – DSG Jun 18 '14 at 13:10
  • Line numbers change between releases. Either post the relevant line and some context or post your Magento version and make sure the files are pristine (no core hacks). – Melvyn Jun 18 '14 at 18:44
  • Thank you, I edited the post. My magento version is 1.8.1.0 and I didn't changed any core file. My var folder permissions are set to 777 and I was already logging in the DB as root. – Niko Zarzani Jun 19 '14 at 7:07
  • Do you have any apc/memcache/opcache? try to restart php/apache service. – kuba_ceg Jun 19 '14 at 9:35
  • 3
    This question appears to be off-topic because, based on the comments, it seams to have gone away on its own. – Marius Jul 28 '14 at 8:50

Browse other questions tagged or ask your own question.