5

Since Magento 2.2.6 was released not long ago we wanted to update our installation via CLI. Unfortunatly i stepped accross a few problems.

Steps I've done so far

composer require magento/product-community-edition 2.2.6 --no-update

composer update

And thats where the problems kick in, after loading the repos for a while i get the following error:

Your requirements could not be resolved to an installable set of packages. Problem 1 - doctrine/annotations v1.6.0 requires php ^7.1 -> your PHP version (7.0.32) does not satisfy that requirement. - doctrine/annotations v1.6.0 requires php ^7.1 -> your PHP version (7.0.32) does not satisfy that requirement. - doctrine/annotations v1.6.0 requires php ^7.1 -> your PHP version (7.0.32) does not satisfy that requirement. - Installation request for doctrine/annotations 1.6.0 -> satisfiable by doctrine/annotations[v1.6.0].

I thought it will be an easy fix by just using the php71 prefix but it seems like Magento dont want that since i get this line then

- magento/product-community-edition 2.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.22) does not satisfy that requirement.

How do i update if the php requirements are that different ?

1

As the error message you system still taking your old php version your PHP version (7.0.32) does not satisfy that requirement.

Before running this command,

composer require magento/product-community-edition 2.2.6 --no-update

Please do below  step:
  • Stop all Magento CRON, means remove all Magento cron from server cron list.
  • Remove .setup_cronjob_status,.update_cronjob_status,composer.json form var folder.
  • Remove/Flush all magento cache.
  • Whoups, typo. I copied the command from the official docs. I've used 2.2.6. – Marcel H. Sep 19 '18 at 7:45
  • what about - magento/product-community-edition 2.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.22) does not satisfy that requirement.Please update the post accordingly your error – Amit Bera Sep 19 '18 at 7:48
  • There was the misstake. Seems like ive required 2.1.6 instead of 2.2.6... Question can be closed – Marcel H. Sep 19 '18 at 8:07
3

Please upgrade it using composer like that

Edit composer.json in root file from

"require": {
        "magento/product-community-edition": "2.2.5",

To below line

"require": {
        "magento/product-community-edition": "2.2.6",

And after this run command

composer update

After this run

php bin/magento setup:upgrade
  • This entry isn't found in the composer.json file – Mohamed Saleh Oct 23 '18 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.