1

Hello i just put my store to other new server but i have very big problems...
I set right permissions ( owner and group too ) to magento dir but i get this error

Magento\Framework\Exception\NoSuchEntityException: No such entity. in /var/www/vhosts/magento2/httpdocs/vendor/magento/module-store/Model/WebsiteRepository.php:102 Stack trace: #0 /var/www/vhosts/magento2/httpdocs/vendor/magento/module-store/Model/StoreManager.php(204): Magento\Store\Model\WebsiteRepository->getById('0') #1 /var/www/vhosts/magento2/httpdocs/generated/code/Magento/Store/Model/StoreManagerInterface/Proxy.php(135): Magento\Store\Model\StoreManager->getWebsite('0') #2 /var/www/vhosts/magento2/httpdocs/vendor/magento/module-store/Model/Resolver/Website.php(30): Magento\Store\Model\StoreManagerInterface\Proxy->getWebsite('0') #3 /var/www/vhosts/magento2/httpdocs/vendor/magento/framework/App/Config/ScopeCodeResolver.php(49): Magento\Store\Model\Resolver\Website->getScope('0') #4 /var/www/vhosts/magento2/httpdocs/vendor/magento/module-config/App/Config/Source/RuntimeConfigSource.php(87): Magento\Framework\App\Config\ScopeCodeResolver->resolve('website', '0') #5 /var/www/vhosts/magento2/httpdocs/vendor/magento/module-config/App/Config/Source/RuntimeConfigSource.php(63): Magento\Config\App\Config\Source\RuntimeConfigSource->loadConfig() #6 /var/www/vhosts/magento2/httpdocs/vendor/magento/framework/App/Config/ConfigSourceAggregated.php(40): Magento\Config\App\Config\Source\RuntimeConfigSource->get('') #7 /var/www/vhosts/magento2/httpdocs/vendor/magento/module-config/App/Config/Type/System/Reader.php(60): Magento\Framework\App\Config\ConfigSourceAggregated->get() #8 /var/www/vhosts/magento2/httpdocs/generated/code/Magento/Config/App/Config/Type/System/Reader/Proxy.php(95): Magento\Config\App\Config\Type\System\Reader->read() #9 /var/www/vhosts/magento2/httpdocs/vendor/magento/module-config/App/Config/Type/System.php(292): Magento\Config\App\Config\Type\System\Reader\Proxy->read() #10 /var/www/vhosts/magento2/httpdocs/vendor/magento/module-config/App/Config/Type/System.php(191): Magento\Config\App\Config\Type\System->readData() #11 /var/www/vhosts/magento2/httpdocs/vendor/magento/module-config/App/Config/Type/System.php(152): Magento\Config\App\Config\Type\System->loadDefaultScopeData('default')

12 /var/www/vhosts/magento2/httpdocs/vendor/magento/framework/App/Config.php(131):

Magento\Config\App\Config\Type\System->get('default/newreli...') #13 /var/www/vhosts/magento2/httpdocs/vendor/magento/framework/App/Config.php(80): Magento\Framework\App\Config->get('system', 'default/newreli...') #14 /var/www/vhosts/magento2/httpdocs/vendor/magento/module-new-relic-reporting/Model/Config.php(91): Magento\Framework\App\Config->getValue('newrelicreporti...') #15 /var/www/vhosts/magento2/httpdocs/vendor/magento/module-new-relic-reporting/Plugin/HttpPlugin.php(49): Magento\NewRelicReporting\Model\Config->isNewRelicEnabled() #16 /var/www/vhosts/magento2/httpdocs/vendor/magento/framework/Interception/Interceptor.php(121): Magento\NewRelicReporting\Plugin\HttpPlugin->beforeCatchException(Object(Magento\Framework\App\Http\Interceptor), Object(Magento\Framework\App\Bootstrap), Object(Exception)) #17 /var/www/vhosts/magento2/httpdocs/vendor/magento/framework/Interception/Interceptor.php(153): Magento\Framework\App\Http\Interceptor->Magento\Framework\Interception{closure}(Object(Magento\Framework\App\Bootstrap), Object(Exception)) #18 /var/www/vhosts/magento2/httpdocs/generated/code/Magento/Framework/App/Http/Interceptor.php(39): Magento\Framework\App\Http\Interceptor->___callPlugins('catchException', Array, Array) #19 /var/www/vhosts/magento2/httpdocs/vendor/magento/framework/App/Bootstrap.php(261): Magento\Framework\App\Http\Interceptor->catchException(Object(Magento\Framework\App\Bootstrap), Object(Exception)) #20 /var/www/vhosts/magento2/httpdocs/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http\Interceptor))

21 {main}


Also when im trying to make rollback database cli shows me

Maintenance mode already enabled You are about to remove current code
and/or database tables. Are you sure?[y/N]y DB rollback is starting...
No such entity. Skipped disabling maintenance mode

I have over 14k items in my db and im freaky out.

  • Have you removed generated folder and run all commands like di compile and setup upgrade,s:s:d? – Rutvee Sojitra Sep 17 '18 at 12:01
  • well no i didnt use any of this :S can we talk for a while via chat? – darkattack Sep 17 '18 at 12:04
  • [Magento\Framework\Exception\NoSuchEntityException] No such entity. for all commands like bin/magento – darkattack Sep 17 '18 at 12:06
1

Firstly please remove generated, cache and page cache folder

rm -rf generated/* var/cache/* var/page_cache/*

and then run below commands:

php bin/magento setup:di:compile

php bin/magento setup:upgrade

php bin/magento setup:static-content:deploy (if you are using developer mode please add -f)

php bin/magento cache:clean

php bin/magento cache:flush

after running all the commands please refresh your site and check

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.