2
Magento 1.9.1
Porto theme
VPS server:
RAM: 6 GB RAM
Storage: 150 GB SSD
Bandwidth: 6TB
8 cores

Our Hosting company is Hostforweb.com They did this migration from a datacenter in Chicago to New York in December and we are now having serious performance problems (they said the datacenter in Chicago was too expensive). They even said they moved us to a fast machine on a fast node after we complained of performance problems. Today, the sites are loading extremely slow and we get the following Error when going to the Admin login page:

There has been an error processing your request SQLSTATE[HY000] [2006] MySQL server has gone away

> Trace:
> #0 /home/oursite/public_html/lib/Zend/Db/Adapter/Pdo/Mysql.php(111): Zend_Db_Adapter_Pdo_Abstract->_connect()
> #1 /home/oursite/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(320): Zend_Db_Adapter_Pdo_Mysql->_connect()
> #2 /home/oursite/public_html/lib/Zend/Db/Adapter/Abstract.php(460): Varien_Db_Adapter_Pdo_Mysql->_connect()
> #3 /home/oursite/public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php(238):
> Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array)
> #4 /home/oursite/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(428): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array)
> #5 /home/oursite/public_html/app/code/core/Mage/Core/Model/Resource.php(179):
> Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8')
> #6 /home/oursite/public_html/app/code/core/Mage/Core/Model/Resource.php(110):
> Mage_Core_Model_Resource->_newConnection('pdo_mysql',
> Object(Mage_Core_Model_Config_Element))
> #7 /home/oursite/public_html/app/code/local/Amasty/Fpc/Model/Fpc/Front.php(984):
> Mage_Core_Model_Resource->getConnection('core_read')
> #8 /home/oursite/public_html/app/code/local/Amasty/Fpc/Model/Fpc/Front.php(107):
> Amasty_Fpc_Model_Fpc_Front->getDbConfig('web/url/use_sto...')
> #9 /home/oursite/public_html/app/code/core/Mage/Core/Model/Cache.php(703):
> Amasty_Fpc_Model_Fpc_Front->__construct()
> #10 /home/oursite/public_html/app/code/core/Mage/Core/Model/Cache.php(685):
> Mage_Core_Model_Cache->_getProcessor('Amasty_Fpc_Mode...')
> #11 /home/oursite/public_html/app/code/core/Mage/Core/Model/App.php(340):
> Mage_Core_Model_Cache->processRequest()
> #12 /home/oursite/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array)
> #13 /home/oursite/public_html/index.php(87): Mage::run('', 'store')
> #14 {main}
> 
> Error log record number: 540972657870

Where can I find the Error log?

I made a ticket with the hosting company but they just answered this:

Currently, I see 4.55 requests/sec being served by the host which is quite normal and cannot be considered as an attack. However, this causes over 100% load and this is the reason your website is slow. The scripts running in your Magento store require more server resources than your server is providing.

What can I do to make it work again? I restarted Apache, MySQL, and the entire server 3 times.

PS: This is what they said about optimizing Magento:

I have checked your server and found that your website https://www.whateverplace.com/ is generating a large count of HTTP processes which is taking all resources of the server. This was already stated in the same discussion and you need to review your Magento store with a professional developer in order to optimize it.

UDATE:

Now I'm able to go through the steps of placing an order but when I click the SUBMIT button - it gives the following Error:

> There has been an error processing your request SQLSTATE[HY000] [2002]
> No such file or directory
> 
> Trace:
> #0 /home/whateversite/public_html/lib/Zend/Db/Adapter/Pdo/Mysql.php(111):
> Zend_Db_Adapter_Pdo_Abstract->_connect()
> #1 /home/whateversite/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(320):
> Zend_Db_Adapter_Pdo_Mysql->_connect()
> #2 /home/whateversite/public_html/lib/Zend/Db/Adapter/Abstract.php(460):
> Varien_Db_Adapter_Pdo_Mysql->_connect()
> #3 /home/whateversite/public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php(238):
> Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array)
> #4 /home/whateversite/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(428):
> Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array)
> #5 /home/whateversite/public_html/app/code/core/Mage/Core/Model/Resource.php(179):
> Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8')
> #6 /home/whateversite/public_html/app/code/core/Mage/Core/Model/Resource.php(110):
> Mage_Core_Model_Resource->_newConnection('pdo_mysql',
> Object(Mage_Core_Model_Config_Element))
> #7 /home/whateversite/public_html/app/code/local/Amasty/Fpc/Model/Fpc/Front.php(984):
> Mage_Core_Model_Resource->getConnection('core_read')
> #8 /home/whateversite/public_html/app/code/local/Amasty/Fpc/Model/Fpc/Front.php(107):
> Amasty_Fpc_Model_Fpc_Front->getDbConfig('web/url/use_sto...')
> #9 /home/whateversite/public_html/app/code/core/Mage/Core/Model/Cache.php(703):
> Amasty_Fpc_Model_Fpc_Front->__construct()
> #10 /home/whateversite/public_html/app/code/core/Mage/Core/Model/Cache.php(685):
> Mage_Core_Model_Cache->_getProcessor('Amasty_Fpc_Mode...')
> #11 /home/whateversite/public_html/app/code/core/Mage/Core/Model/App.php(340):
> Mage_Core_Model_Cache->processRequest()
> #12 /home/whateversite/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array)
> #13 /home/whateversite/public_html/index.php(87): Mage::run('', 'store')
> #14 {main}
> 
> Error log record number: 539436288523

The orders have NOT been placed. And I'm getting it in the Admin panel as well.

  • 1
    Issue is something related to SQL queries. I think you need to check if there are any triggers set in your database and also check which query takes more resources. – Sukumar Gorai Sep 13 '18 at 18:36
  • @allysin What is your situation today? Have not heard from you. Thanks – Wilson Hauck Dec 12 '18 at 15:33
  • @Wilson Hauck I completely missed your messages-sorry!The situation with our hosting company is so bad that I will setup new on a new host! The existing hosting company=Hostforweb lied to us! We were suppose to have 8 cores with 6GB RAM and did not have anything even close) Now they claim they put us on a 8-coes 6GB RAM VPS account but we still see many performance problems due to load spikes. When I raise a ticket-they say that another account on the same node is doing a backup and that's why OUR performance is affected because that apparently happens on a shared VPS account for $89.95/month? – Allysin Dec 12 '18 at 18:41
  • @Wilson Hauck I never did the script optimizing - I am now just trying to solve a problem with our product photos not loading in the Product pages in Admin = magento.stackexchange.com/questions/249348/… and waiting on Magento to release a stable verion of 2.3 and setup on that on the new host (hosting account) – Allysin Dec 12 '18 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.