0

I am having an issue in Magento Admin. The import/export menu is not visible. When I open the URL directly, It shows a blank page.

enter image description here

enter image description here

Please help, it's urgent.

  • Did you change anything or installed new module? – Sukumar Gorai Sep 13 '18 at 13:58
  • Yes, I have some custom modules installed, I disabled them all and then tried, but it was having same issue – Manish Joy Sep 13 '18 at 14:01
  • can you check log? – Sukumar Gorai Sep 13 '18 at 14:01
  • yes, no error over there too. – Manish Joy Sep 13 '18 at 14:07
  • Are you admin user with administration role? Or you have created any user which doesn't have enough permission? – Sukumar Gorai Sep 13 '18 at 14:08
2
+25

There are a few ways to debug it.

  • Check in administrator role that Import/Export is not un-selected.
  • Can you create a new user using command bin/magento admin:user:create and login to admin panel using these newly created credentials to check if you can see Import/Exports.
  • Disable all the custom modules one-by-one to figure out which module is causing issue.
  • Enable developer module using command bin/magento deploy:mode:set developer and afterwards check if you can find something in log.
0

You have 3 methods that I can see:

solution 1: find the string Magento_Backend::system_convert into your codebase (app/code and vendor/magento). Then, hopefully, that should show your your items menu nodes as per the screenshot below.

enter image description here

If you find the, that is half of the battle sorted as you just have to work out why they don't show up. You may try shorter versions as it may have been mispellt accidentally.

solution 2: If you don't find them, I suggest you could create a new menu node in a custom module:

<?xml version="1.0"?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:module:Magento_Backend:etc/menu.xsd">
    <menu>
        <add id="Magento_ImportExport::system_convert_import" title="Import" translate="title" module="Magento_ImportExport" sortOrder="10" parent="Magento_Backend::system_convert" action="adminhtml/import" resource="Magento_ImportExport::import"/>    
    </menu>
</config>

The key is your new menu item should have the action value set to: action="adminhtml/import"

solution 3: I am still assuming admin permissions and all the suggestions kindly made have been checked of course. This method is more drastic but you can delete vendor folder and run composer install. (Make a backup is always useful)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.