I have upgraded Magento from 2.1.10 to 2.2.5. First I have upgraded it locally and all things are working in local then I have upload those source code in beta and did following process :

php bin/magento s:up

php bin/magento s:s:d

php bin/magento c:c

php bin/magento c:f

php bin/magento i:rei

In beta database was of Magento 2.1.1 but after did above process now my Magento is 2.2.5.

All things are working but the Category and Product detail page is not opening. It is showing blank a white page.

I checked error in var/log but no error. I have enabled the error in index.php but still no luck.

I gave permission to var and generated directories.

I changed theme to default theme and also tried by disable all extension.

  • Did you run di compile? – Sukumar Gorai Sep 12 '18 at 12:31
  • Yes I did. But no error – David Coder Sep 12 '18 at 12:38
  • Can you try reindex once again after doing all these? – Sukumar Gorai Sep 12 '18 at 12:39
  • Yes sorry I forget to add but I did it. – David Coder Sep 12 '18 at 12:40
  • You have to enable developer mode and see what errors are coming – Amit Bera Sep 12 '18 at 13:49

I found the solution and want to share with you so It can be helpful for others.

Actually, I am using porto theme and the issue is in placeholder image. The name of the images are different than the database.

I re-upload the images and it is working now. But I can't understand why it totally stops the catalog and product page to be run. It should display the error. Anyway, it is working now.

  • I have exactly the same problem with my porto theme on M2 2.2.3, but i dont understand your feedback. You reupload the product images, after the category and product detail pages are working? I have over 200 products, i can`t reupload all images... :-( – FloWord Jan 24 '19 at 20:32
  • You dont't need to re-upload all product image you just need to re-upload the place holder image – David Coder Jan 25 '19 at 11:03
  • uploaded the product placeholder images on Catalog->Product Image Placeholfers->Base/Small/Swatch/Thumbnail done, but no luck. Any other solution? bambi.ch/elastisches-tragetuch-mit-motiv-5-4m-lang.html – FloWord Jan 26 '19 at 8:55
  • Make sure your theme configuration -> category view -> page layout is correct. like 2 column with left side etc... – David Coder Jan 28 '19 at 5:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.