4

Just testing my shipping for a logged-in customer on Magento 2.2.5

When I come to the checkout I get the following error.

Please check the shipping address information. Invalid value of "183" provided for the regionId field.

An address that I previously used is going through fine but this seems to happen when I try to enter a new address. A screenshot is provided

enter image description here

Having tested this it seems that this error occurs when the billing and shipping addresses are in a different country.

I realize that it would be a rare occurrence when the payment method is registered to a different country to a billing address but I wondered if there was any way to get around this for instances where the user is in temporary accommodation (working in another country for example) or is ordering for someone else (for example if someone in Northern Ireland is ordering for an address in the Republic of Ireland then they would technically be in a different country).

1
  • For some reason entering a default billing address seems to have resolved this problem. Still unsure how this has occurred but for now seems to be a good workaround
    – CJNotts
    Sep 12 '18 at 9:21
6

@CJNotts

This error occurs when once integer is stored for State/Province field, it can not be changed to alphanumeric .

Please go through this https://github.com/magento/magento2/issues/14052 .

You can fix this by making changes to the core file

Path magento_rootdirectory/vendor/magento/module-customer/Model/Address/AbstractAddress.php

line 650 function validate

change

elseif ($regionId && !in_array($regionId, $allowedRegions, true)) {

to

elseif ($regionId && !in_array($regionId, $allowedRegions, true) && !empty($allowedRegions)) {

Hope this helps .

7
  • Thanks. Just checked out the page and it looks exactly like what I'm experiencing here. I'll make the change.
    – CJNotts
    Sep 12 '18 at 9:19
  • happy that it worked for you .
    – Mac
    Sep 14 '18 at 12:18
  • @RahulMakwana, this didn't work for me Dec 4 '18 at 7:31
  • @jafar I would like to help you out , are you getting the same error ? which version of magento ?
    – Mac
    Dec 4 '18 at 13:27
  • @RahulMakwana, I am using 2.2.4 Dec 4 '18 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.