1

I am trying to install a magento 2 extension. Facing this exception error on website.

1 exception(s):
Exception #0 (Magento\Framework\Exception\LocalizedException): Please upgrade 
your database: Run "bin/magento setup:upgrade" from the Magento root directory. 
The following modules are outdated:
******_*** schema: current version - 1.0.1, required version - 1.0.0
******_*** data: current version - 1.0.1, required version - 1.0.0

3 Answers 3

0

As error displays its solution. You have to fire the following command using Magento cli,

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy

if you still found the same error message you should remove entry from setup_module table and re run the above commands.

0

For some reason there is a module (the one you marked with ***_***) that is at a higher version than it is required.
Not sure how this happened.
But you can do one of the following.

  • edit module.xml of the module in question and set the version to 1.0.1
  • run this query update setup_module set data_version = '1.0.0', schema_version = '1.0..' where module = 'your module name here';

I would go with the second one.

0

You must go to the DataBase and remove the rows from the modules which give the error. Then run:

rm -rf pub/static/*; php bin/magento setup:upgrade; php bin/magento setup:static-content:deploy

Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.