1

In Magento 2.1.7 when I have customized some js as per our requirement in app\design\frontend\vendor\theme\Magento_ProductVideo and then fire following commands

php -dmemory_limit=6G bin/magento setup:upgrade
php -dmemory_limit=6G bin/magento setup:static-content:deploy

Then I found the files are renamed xxx_temp.min.js instead of xxx.js in pub/static area.

Thanks.

3
  • You have to disable js minification in admin configuration. Commented Sep 11, 2018 at 6:29
  • @Rizwan I have tried it, after that, I have fired the above commands again also. But no luck.
    – Knight017
    Commented Sep 11, 2018 at 6:33
  • The minification wasn't the problem, actually the core file in vendor directory was renamed xxx_temp.js. So after minification, it becomes xxx_temp.min.js.
    – Knight017
    Commented Sep 13, 2018 at 3:57

1 Answer 1

1

You have to disable the minify javascript files to NO

enter image description here

After that remove pub/static/frontend and pub/static/_cache directories.

Flush your Magento cache using CLI. php bin/magento c:f
Deploy static content php bin/magento s:s:d

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.