1

I've run into a dead end trying to install an extension and am hoping for some guidance. The extension is Blackbird_ContentManager -- great extension and support overall, but I can't figure out what's going on here.

At first, I received

Blackbird_ContentManager data: current version - none, required version - 2.2.12

So when I run setup:upgrade, it got to Installing Data and then:

SQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or 
update a child row: a foreign key constraint fails 
(`db_5798qz73hik`.`eav_entity_attribute`, CONSTRAINT 
`EAV_ENTITY_ATTRIBUTE_ATTRIBUTE_ID_EAV_ATTRIBUTE_ATTRIBUTE_ID` FOREIGN 
KEY (`attribute_id`) REFERENCES `eav_attribute` (`attribute_id`) ON D), 
query was: INSERT INTO `eav_entity_attribute` (`entity_type_id`, 
`attribute_set_id`, `attribute_group_id`, `attribute_id`, `sort_order`) 
VALUES (?, ?, ?, ?, ?)

Sometimes it'll make it it to the "Installing Data" phase of setup, but then I'll receive "Wrong entity ID" error. This is after deleting all relevant eav_* and blackbird_* tables/rows, as well as the entry in setup_module.

Obviously, I'm doing something wrong here, but I'm unsure what to do that I haven't already done and am getting increasingly nervous. Any help would be appreciated!

4
  • Delete all the data related to this extension and remove the entry from setup module table and then run setup upgrade. – Sukumar Gorai Sep 10 '18 at 15:56
  • Hey @SukumarGorai -- I've actually already tried that, edited question to reflect that. Thank you. – brackfost Sep 10 '18 at 16:04
  • can you try in your extension first disable the foreign key check and after execution of query enable foreign key check. – Magento Dev Sep 11 '18 at 5:16
  • Tried that earlier, wasn't successful. My issue has been resolved, though, see below. – brackfost Sep 11 '18 at 13:45
0

Ended up solving this by resetting auto-increments on all relevant tables. A product transfer integration added a bunch of attribute sets/attributes, which somehow threw the increments out of wack.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.