0

I am using a custom theme with blank as parent. Everything works well but I noticed that on responsive screens the hamburger menu seems broken. When I click on it nothing happens while I expect the navigation menu to show up.

The version of the Magento installation is 2.2.5
I tried inheriting the menu.js and extended only the toggle function but still it does not work

Is there anyone who has experienced the same issue and can give some advice?

!UPDATE! event handler is not attached to the element! It is though attached only on login screen and there the button works properly

enter image description here

4
  • can you describe with screen shot. Sep 14, 2018 at 10:19
  • @AakashJoshi Please review again the question as i updated it!
    – George Geo
    Sep 14, 2018 at 10:30
  • I just review snap, I have observed this issue is related to jquery. can you please tell me verify is there any js related error in browser console window? Sep 14, 2018 at 12:33
  • Unfortunately i get no errors! What i can tell though is that the menu.js is not loaded. I saw that from the network monitor that everything is being fetched from responsive.js , matchMedia.js but not menu.js!
    – George Geo
    Sep 14, 2018 at 13:10

1 Answer 1

0

We had the exact same problem and it turned out to be because we had recently enabled Varnish Cache.

1
  • And... did you get an actual solution? Feb 25 at 9:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.