2

I was configuring Magento CE to use a SSL certificate. I navigated to Configuration / Web / Secure and enabled SSL. Then I did the wrong thing, I think. I changed the secure URL path to https://www.example.com/ and now I am locked out of the back end, showing “SSL connection error”. My website is up, but checkout is not working. I think. I have cleared the cache on my browser, and tried some others.

I did a search on the error, and the fix seems to be: to go into phpmyadmin, find core_config and change the value of web/secure/use_in_adminhtml from 1 to 0.

I cannot find the path web/secure/use_in_adminhtml. The closest I can find is web/secure/base_url. The post is from 2011, so it may have changed since then. You can read the post here http://www.magentocommerce.com/wiki/recover/ssl_access_with_phpmyadmin . I am using Magento 1.8 now. I have a very basic understanding of phpmyadmin, so am much more likely to stuff it further, so please advise me.

  • 1
    Change web/secure/base_url in core_config_data back to the correct URL – user9255 Jun 17 '14 at 13:00
2

You are on right path.

The reason you are not finding the config path web/secure/use_in_adminhtml in the table is because it was never set in admin.

Only values that are adjusted, or have values saved will get set in the table. If they don't exist, the defaults will be used. Defaults can either exist from code, or via the respective module's config.xml in the <defaults> tag (or via the config.xml/local.xml in the etc folder as well)

Since you are using a ssl url, you would want to set the value to 1, not 0 (which is the default)

So, to solve you issue, you have two options:

a. Manually insert the entry for web/secure/use_in_adminhtml into your core_config_data table

The following SQL will do that for you:

INSERT INTO core_config_data (scope,scope_id,path,value) VALUES ('default',0,'web/secure/use_in_adminhtml',1);

b. Change the url in the table back to http://your.domain.com/ (remember the end slash)

In either case, clear the cache (manually by deleting /var/cache)

You should now be able to get back to admin.

2

For reference this is the Magento web page linked to in the question:

How to restore Admin access for failed TLS/SSL access with phpMyAdmin

Symptoms: TLS/SSL Socket 443 failure is preventing access to my Administrative (backend | control panel) or my Admin has been set to use secure access before TLS/SSL has been activated

  1. Open your core_config_data table in phpMyAdmin.

  2. Find the row with the path web/secure/use_in_adminhtml and change its value field from 1 to 0 to enable accessing admin panel from unsecure http://www.yourwebsite.com/admin url

    Changing web/secure/use_in_frontend toggles customer shopping cart security, 1=on and 0=off which probably isn't of importance as you're trying to regain administrative access

  3. Clear var/cache, var/session. This is necessary because your config is cached and clearing it forces a reread of the configuration data from the core_config_data table.

You should now be able to access your Magento Admin panel by standard unsecured web access (port 80, http).

NOTE: Be aware that accidentally entering your leading https:// instead of http:// on your unsecure_base_url before you have enabled TLS/SSL on your webserver will lock you out, so if the above doesn't get you in, look for rows with web/unsecure/base_url, and check for the aforementioned misconfiguration.

-1
  1. first go to phpmyadmin in controlpanel
  2. Then select your database that you created
  3. Then select wpco_options
  4. change the siteurl & home to your domain name, example: https://domain.com to http://domain.com

that's it. it worked for me but i can't say whether it works for you or not.

  • Are you sure, you are talking about Magento? – Fabian Schmengler Dec 9 '15 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.