0

I am trying to use Xdebug for magento 1. However, Xdebug no longer supports PHP under 7.0. Magento 1 on the other hand only works for php 5.

Does anyone know any solution to this problem. enter image description here

4
  • just install an older version .. Sep 9 '18 at 18:43
  • yes. good point. but where to find an older version? there site does not have an older version
    – theSeeker
    Sep 10 '18 at 5:14
  • yes. but where do i get the old version from . its not on their site
    – theSeeker
    Sep 10 '18 at 10:21
  • Do note that PHP 5.6 will reach EoL at the end of this year. To stay PCI compliant, you'll need PHP 7.2. I recommend developing against 7.2 to stay ahead of this curve (unless you are 100% sure that the bug you're debugging is specific to PHP 5.6). Sep 11 '18 at 17:58
1

You can download older versions of xdebug which are compatible with php 5.

You can see and download all the versions released till now here - https://xdebug.org/download.php

Just scroll down and look for a compatible version to your corresponding php.

2
  • my bad. i did not see it. thanks mate
    – theSeeker
    Sep 11 '18 at 10:04
  • Np, Glad I could help! Sep 11 '18 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.