I have installed a fresh magento 1.9 on my vps running with nginx. My root folder of magento is /var/www/abc.hello.com/datazone/ and also set ownership as www-data as user and www-data as group (www-data nginx user). every thing goes fine while installing magento, did not show any permission error.

After installing magento, I go to admin pane system -> magento conncet -> magento connect manager, did not show any permission error on magento connect manager then i try to install "PageCache powered by Varnish" with Magento Connect 2.0 key, i paste the extension key to install, then clicked on proceed to install. In magento connect manager console at bottom it show

checking dependencies of packages
starting to download Varnish_Cache-4.0.5.tgz ...
...done: 34,730 bytes

It does not further move to installation process.

Is the problem of my installation? or permission problem ? or some think else ? I am unable to install any extension due to this big problem. I am new in magento :) Thanks in Advance.

  • I dont think the extension you shared is compatible with 1.9 Commented Jun 17, 2014 at 8:35
  • ok but Fooman Speedster is compatible with 1.9 and same problem again while installing Fooman Speedster its stop at ...done:...... process
    – Beginner
    Commented Jun 17, 2014 at 8:43
  • Did you installed at fresh magento, I am sure Fooman works fine with frsh magento, it could be any customization conflict. What error is showing Commented Jun 17, 2014 at 8:45
  • same as above just replace Varnish_Cache-4.0.5.tgz with Fooman_Speedster-3.0.14.tgz ... the main problem is i can not install any extension using magento connect manager :(
    – Beginner
    Commented Jun 17, 2014 at 8:47
  • Tried manually adding them? Commented Jun 17, 2014 at 8:53

5 Answers 5


Try this may be its use full to you. It solved my problem.
Go to downloader/lib/Mage/Archive/Helper/File/Gz.php in your Magento directory
and replace

$this->_fileHandler = @gzopen($this->_filePath, $mode); 


$this->_fileHandler = @gzopen64($this->_filePath, $mode);

This is not fixing the problem, but if you look in your file system, navigate to -


you should see the package you downloaded as .tgz archive.

You can download this, extract, and then upload directly to your store.


I had the same problem.I searched for hours to this problem. I had a problem related to permission to the files and folders..I solved it as follows...

  1. Go to "settings" tab of "Magento connect manager".
  2. Then select "yes" for the field "Use custom permissions:"
  3. Then save settings.
  4. Now do the general process of installing extension in the "Extension" tab section.

Hope this helps...

  1. Go to admin panel -> system -> magento connect -> click on magento connect manager u get redirected to magento connect manager page.
  2. Now in Install New Extensions block enter the extension key what you got from magento commerce and click on install
  3. If in console u see this checking dependencies of packages starting to download Varnish_Cache-4.0.5.tgz ... ...done: 34,730 bytes which in backend this succesfully downloaded u can see the file in magento root->downloader->.cache->community there u can find u extension with tz file format
  4. Copy that file to desktop and extract to tar format now come back to u magento connect go to Direct package file upload block and select this tar file and upload and install u can see changes in admin panel u can see u r extension in Manage Existing Extensions block itself

The logging with Magento Connect doesn't always make clear what the cause of the error is. Some errors are suppressed in the code.

Using a PHP debugger will help answer question more specifically as it will let you go through the code execution during Magento Connect to find the problem and fix it.

Xdebug is a popular open-source PHP debugger that works with Nginx as well as Apache (and most open-source IDE's).

  • omg, please read my problem before giving advice. xdebug on nginx!
    – Beginner
    Commented Jun 19, 2014 at 21:51
  • Sorry and I apologize for my mistake.
    – Beginner
    Commented Jun 21, 2014 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.