I know there's a million of these questions with answers but I still can't solve this. It does create the line in the core_resource table, but my install script is supposed to die to show it's running, and it isn't.

Relevant code: (with changed Namespace/Module names) /var/www/html/app/code/local/Namespace/Module/etc.config.xml


In /var/www/html/app/code/local/Namespace/Module/Model/Resource/Setup.php:

class Namespace_Module_Model_Resource_Setup extends Mage_Core_Model_Resource_Setup {}

And then I made my installer script in /var/www/html/app/code/local/Namespace/Module/sql/module_setup/mysql14-install-0.0.1.php:

echo 'Running This Upgrade: '.get_class($this)."\n <br /> \n";
die("Exit for now");

My steps for testing if it's working is this. I clear my cache from the Admin Cache Management page (although I have caching disabled anyways). Then I delete my module_setup entry from core_resource. Then I go back to the admin panel and refresh the page. When I do so, it recreates module_setup in the table, however it doesn't appear to execute my mysql14-install-0.0.1.php script because it doesn't die. Nothing appears in the logs (yes they're enabled). Please can someone see what I'm missing here? Is it a simple naming scheme or directory issue? I've been over the tutorials and answers so many times and still can't see what's wrong.

1 Answer 1


I considered just deleting the question when I found out how dumb my issue was, but you know what, someone out there will make the same silly mistake and be just as confused as me so I'll leave it up here. The issue was that I named my install script mysql14 (fourteen) instead of mysql4 (four). I don't even know what the number represents. I'm running mysql version 14 so who knows. But let this help out some other poor soul: it's four.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.