I move my magento project from localhost to shared server. Now since mod_version was not installed and the hosting provider said that enabling the module was not covered of the plan. So I followed the link below as a work around to make it run.

Magento 2: Apache mod version not enabled/installed/allowed by host, causes 500 error on all pages due to failing .htaccess files

After all the hard work, the magento now was running but I got the following error whenever I try to log out in admin side

[30-Aug-2018 01:09:57 UTC] PHP Warning:  Uncaught Exception: Warning: SessionHandler::open(): Cannot call session save handler in a recursive manner in /vendor/magento/framework/Session/SaveHandler.php on line 72 in vendor/magento/framework/App/ErrorHandler.php:61
#0 [internal function]: Magento\Framework\App\ErrorHandler->handler(2, 'SessionHandler:...', '/home/username...', 72, Array)
#1 /vendor/magento/framework/Session/SaveHandler.php(72): SessionHandler->open('host_here...', 'admin')
#2 [internal function]: Magento\Framework\Session\SaveHandler->open('host_here...', 'admin')
#3 /vendor/magento/framework/Session/SessionManager.php(189): session_start()
#4 /generated/code/Magento/Framework/Message/Session/Interceptor.php(50): Magento\Framework\Session\SessionManager->start()
#5 /vendor/magento/framework/Session/SessionM in /vendor/magento/framework/App/ErrorHandler.php on line 61
[30-Aug-2018 01:09:57 UTC] PHP Fatal error:  session_start(): Failed to initialize storage module: user (path:host_here:port_here) in /vendor/magento/framework/Session/SessionManager.php on line 189

Before I am using files to store session but I experiencing random/immediate logout whenever I do basic operations (add items, edit, etc.). Followed everything I find on google but no luck. Now I switched to memcached and it solved the issue. (I already experiencing the log out issue here.)

So now i using memcached to store session files. I assume that logout issue will be solve but when I tried to log out its still not redirecting and stuck in http://sub.domain.com/admin/admin/auth/logout/key/unique_key_here/ and error_log shows above error.

Didn't experience this on localhost. Im using v2.2.4. Please help anyone!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.