0

Note: I'm aware of the existing question. This is a different, more specific question.

A bigger multi-store setup recently stopped to show new products unless I run
bin/magento indexer:reindex.

After investing I came across this bug report. It turned out that the cron-job does actually properly index the new product (it shows up in the corresponding index tables). So the problem shouldn't lie with the indexer. When I set indexing to Update on save by running
bin/magento indexer:set-mode realtime
everything works as expected. Of course that's not a permanent solution. Neither is reindexing for every added product.

I assume that indexer:reindex also clears cache tags so I figured it might actually be a cache problem. Flushing or deactivating the cache didn't do anything, though.

I would appreciate any pointers on fixing this.

0

When you import products product data was not inseted in cataloginvetory-stock (stock related) data not that table

And when you trying to display data without reindexing Its all check in foreach($productcollection as $product) (Is in stock or not, availablity, salebale) All the thing

So when you reindex it then this all the data will be inserted on perticulars product tables that why

  • I'm adding the products via the regular Magento2 Backend which worked until two weeks ago and just stopped working now. The stock-info is also properly added when adding the new product. – mniess Sep 3 '18 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.