1

Anyone can help me this problem ?

Please execute 'magento-cli' instead of 'magento' that uses the proper user to execute any Magento's command

This problem happen when i run command : php bin/magento setup:upgrade

Thanks

3

Simple, just using 'magento-cli' instead of 'magento'

Example :

sudo bin/magento-cli setup:upgrade
sudo bin/magento-cli setup:static-content:deploy -f
sudo bin/magento-cli indexer:reindex
sudo bin/magento-cli cache:flush
2

1. Login to your account using ssh

2. At the command prompt, change to the directory where Magento is installed. For example, if Magento is installed in the document root directory, type cd ~/public_html.

3. Type the following command to make the CLI executable

chmod 744 bin/magento

4. To run the CLI and view the available command options, type the following command

bin/magento
  • Thanks you, it works, or run command : sudo bin/magento-cli instead of sudo bin/magento – Vu Tran Kien Aug 29 '18 at 6:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.