2

How do I get Fix this Error?

Check Component Dependency
We found conflicting component dependencies. Hide detail

Command "update" failed: Loading composer repositories with package information


[Composer\Downloader\TransportException] 
The "https://repo.magento.com/packages.json" file could not be downloaded: allow_url_fopen must be enabled in php.ini (https:// wrapper is disabled in the server configuration by allow_url_fopen=0 
failed to open stream: no suitable wrapper could be found) 


update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages>].
0

Try this:

you need enable allow_url_fopen.

You can check whether the allow_url_fopen is enabled by executing the following command in the root Magento 2 folder:

php -i | grep allow_url_fopen

Edit your php.ini, find allow_url_fopen and set it to allow_url_fopen = 1

  • THANK YOU !!! It was only turned on in the sub directory for the new domain. I had to turn it on for main domain website as well for it to work. It did. – PWL Aug 25 '18 at 12:28
  • so your problem solve? – kunj Aug 25 '18 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.