8

My Magento having over 1 lakh products orders, but graph not showing according to sale on magento admin dashboard. please help me what i need to do. Graph showing blank. no graph image is showing. Thanks in advance

  • first you should check internet Connection – HaFiz Umer May 22 at 8:04
3

Go To

app\code\core\Mage\Adminhtml\Block\Dashboard\Graph.php

Check your api url,

 const API_URL = 'http://chart.apis.google.com/chart';

Change code for API URL, and then re-index.

5

Here the Solution

Edit the file at app/design/adminhtml/default/default/template/dashboard/graph.phtml

Find this line getChartUrl(false) change to getChartUrl(true)

  • this one works nicely. – fja3omega Aug 29 '18 at 8:27
2

Taken from this site

Solution 1:

Allow access to this URL on your firewall: http://chart.apis.google.com/chart

or

Solution 2:

Make sure Magento does not try to fetch the image through PHP Locate this file: app/design/adminhtml/default/default/template/dashboard/graph.phtml And change: "getChartUrl()" to "getChartUrl(true)"

This will cause Magento to just return the image location at http://chart.apis.google.com/chart instead of downloading it through PHP.

Both solutions seem to work great. But Solution 2 could throw a warning if you are running your Magento back-end on an SSL connection (which should be doing by the way!)

After implementing this solution the Magento charts or graphs are shown and you can again admire your sales figures!

  • Thanks for answer , sorry buddy but i also go through this link , actully error is the image created by magento ajax function for graph in base 64 bit is not correct. please specify this. – Rock Jun 13 '14 at 10:18
  • Ah, sorry. You should edit your question to specifically target that question. – Zac Grierson Jun 13 '14 at 10:22
  • Question is simple dude, that graph is not showing on magento admin dashboard – Rock Jun 13 '14 at 10:23
0

If the problem is just related to 24 Hours Chart it can be cased by minimal allowed GET variable length settings of suhosin as Titan Lee described on his blog:

This is related to the minimal allowed GET variable length settings. Check your settings for suhosin:

Add/Edit line - > suhosin.get.max_value_length = 1024

So, edit: /etc/php5/fpm/conf.d/suhosin.ini If the above file doesn't exist for you. Then locate & edit, /usr/local/lib/php.ini

http://titanlee.com/my-stuffs/geekystuffs/solved-magento-dashboard-chartgraph-broken/

0

In case anyone else bumps into it ....

For me it was modsecurity blocking the request because it was detecting multiple URL encoding. It was rule 950109 in our default WHM config.

0

In case you've been googling this in 2019 - this is an issue with deprecated Google Image Chart API. There is a Magento 1 module that fixes missing charts - https://github.com/onilab/magento-1-google-api-chart-fix

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.