I seem to have a problem with the reset-password-page in Magento 2.2.5. On my dev server with email configured, I successfully receive the reset-password-link via mail. Checking the database reveals that the rp_token is updated once I request a new password reset. However, visiting the reset link gives me a magento-404-page. ("Whoops, our bad...").

I also tried to create a fresh local install of Magento 2.2.5. Except I didn't set up email and just used the URL pattern to manually create the reset link with the corresponding data from the database (after I went through the forgot-password-form, so the token gets updated). Still the same 404 error.

It doesn't seem to be a problem with Magento itself since I also tried a fresh install of Magento 2.1.7 with the same


I configured the email service via mageplaza/module-smtp on my fresh Magento 2.1.7 install and the reset-password link works now. So the problem seems to lie there. The original install on my dev server is actually a migration from Magento 1 to Magento 2, I haven't touched the email settings since they were working fine for everything else. I'll try to mess around with the settings and keep this post updated, in case anyone runs into a similar problem.

disclaimer: this is my first Magento project

Edit 2:

Configuring mageplaza/module-smtp on my dev server didn't seem to help. All emails are being sent correctly, but the reset-password-link is still returning a 404 error.

Last Edit:

Looks like reverting the email templates back to the corresponding defaults at "Stores>Configuration>Customers>Customer_Configuration>Password_Options" in combination with a configured mageplaza smtp-module has solved my issue.

1 Answer 1


In my situation, there was an extra word "admin" appearing in the reset URL.

So in the password reset email received a link that caused 404 like:


The URL worked after I changed it to:


Now I'm trying to figure out where the "admin" can be removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.