1

I am publishing my magento extension but in the revision I was notified of the issue:

enter image description here Does anyone have any useful help?

  • Did you solve your issue? Was my answer any help? – Vivek Kumar Aug 13 '18 at 16:36
  • thanks for your help. I have already removed all tags cacheable = "false" from my extension but the problem persists. Any other idea? Thank you. – Gianfranco Oliva Aug 13 '18 at 19:34
0

It seems you've added cacheable="false" on some block located in product view page i.e. catalog_product_view.xml due to which cache is getting disabled for entire product view page as mentioned here - https://devdocs.magento.com/guides/v2.3/extension-dev-guide/cache/page-caching.html

Cacheable and uncacheable are terms we use to indicate whether or not a page should be cached at all. (By default, all pages are cacheable.) If any block in a layout is designated as uncacheable, the entire page is uncacheable.

So, you must work on some workaround to disable cache for your own block if you had done cacheable="false" intentionally i.e hole punching in magento full page cache.

I good start will be https://stackoverflow.com/questions/9120413/how-do-i-include-a-dynamic-block-in-the-product-page-with-full-page-caching-turn/9125519#9125519

| improve this answer | |
  • thanks for your help. I have already removed all tags cacheable = "false" from my extension but the problem persists. Any other idea? Thank you. – Gianfranco Oliva Aug 13 '18 at 17:12
0

FYI if your not using layout / view and still get this problem see

how to set no-cache HTTP headers in controller in magento 2

this is how you can set your controller/observer to use no cache and avoid this error

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.