2

I'm attempting to setup my own WAMP server and use Magento 2. I've installed to my machine however in my apache error log I get

IfVersion', perhaps misspelled or defined by a module not included in the server configuration

I'm not sure what to do. Any help would be much appreciated thanks.

  • 1
    your PHP and apache version ?? – Murtuza Zabuawala Aug 8 '18 at 10:48
  • Apache Version: 2.4.33 PHP Version:5.6.35 – Greg Aug 8 '18 at 10:59
  • Try turning on the apache module version_module – Aravona Aug 8 '18 at 11:39
3

you need to enable the IfVersion module on the server

enter image description here

2

IfVersion', perhaps misspelled or defined by a module not included in the server configuration

This is the missing version_module from apache - it will be used to check your PHP version which for Magento 2 is PHP 7, you will need to install this on your WAMP if you are using php 5 currently, or if already installed just switch to this version under the PHP versions tab.

  • This fixed one of the errors however i then had to double check my php version on wamp and then it was fixed. Thanks for the help – Greg Aug 8 '18 at 14:40
  • Yes I said in my answer that you would have to install or change your php version :) – Aravona Aug 8 '18 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.