0

When I am running composer update I am faced with the error like:

$ ./composer update
X-Powered-By: PHP/7.0.31
Content-type: text/html; charset=UTF-8

Warning: Composer should be invoked via the CLI version of PHP, not the cgi-fcgi SAPI
Loading composer repositories with package information
    Authentication required (repo.magento.com):                                                                                                                                                                        Authentication required (repo.magento.com):                                                                                                                                                                        Authentication required (repo.magento.com):
      Username:

  [Symfony\Component\Console\Exception\RuntimeException]
  Aborted


update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [--with-all-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages>]...

does anyone face similar issue and how it can be fixed?

2

It's telling you to enter your magento 2 repo credentials:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.