0

I have a Magento 2 site on version 2.1.8 and I am attempting to upgrade to 2.2.5 with the Web Setup Wizard. When I run the readiness check, it fails on Component Dependency.

My composer.json file contents is below. It's identical to a fresh composer.json from the source archive.

{
"name": "magento/project-community-edition",
"description": "eCommerce Platform for Growth (Community Edition)",
"type": "project",
"version": "2.1.8",
"license": [
    "OSL-3.0",
    "AFL-3.0"
],
"require": {
    "magento/product-community-edition": "2.1.8",
    "composer/composer": "@alpha"
},
"require-dev": {
    "phpunit/phpunit": "4.1.0",
    "squizlabs/php_codesniffer": "1.5.3",
    "phpmd/phpmd": "@stable",
    "pdepend/pdepend": "2.4.0",
    "fabpot/php-cs-fixer": "~1.2",
    "lusitanian/oauth": "~0.3 <=0.7.0",
    "sebastian/phpcpd": "2.0.0"
},
"config": {
    "use-include-path": true
},
"autoload": {
    "psr-4": {
        "Magento\\Framework\\": "lib/internal/Magento/Framework/",
        "Magento\\Setup\\": "setup/src/Magento/Setup/",
        "Magento\\": "app/code/Magento/"
    },
    "psr-0": {
        "": "app/code/"
    },
    "files": [
        "app/etc/NonComposerComponentRegistration.php"
    ]
},
"autoload-dev": {
    "psr-4": {
        "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
        "Magento\\Tools\\": "dev/tools/Magento/Tools/",
        "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
        "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
        "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
    }
},
"minimum-stability": "alpha",
"prefer-stable": true,
"repositories": [
    {
        "type": "composer",
        "url": "https://repo.magento.com/"
    }
],
"extra": {
    "magento-force": "override"
    }
}


Check Component Dependency
We found conflicting component dependencies. Hide detail
For additional assistance, see component dependency help.

I checked the component dependency help page, but since I get no reference to WHICH dependency is the problem, I'm not sure where to look. Not sure what I should do. All attempts at upgrading have failed thus far.

Is there a step I'm missing? Do I need to update the current file set using composer with update and install? I cleaned the composer cache for good measure but no change from that either.

Any help would be appreciated.

  • Did you find the solution? @Marisa – Gem Jan 11 at 12:36
  • I did finally. Memory exhaustion error. – Marisa Jan 11 at 13:16
  • Can I get more details? @marisa – Gem Jan 11 at 14:19
  • I used the Network Inspector to find that I was running out of memory on that check. The Magento 2 htaccess file was limited to 128M so I bumped it to 768M and it worked perfectly afterwards. – Marisa Jan 11 at 16:19
  • I extend my memory_limt 1024M, still getting an error, ant help. Screen Shot : snag.gy/yu9FUd.jpg – Gem Jan 12 at 4:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.