5

In magento admin while adding products image is not uploading.I tried by uploading in different browsers but it too doesn't worked.I have given 777 file permissions to media folder.When i upload image, image is stored in media/tmp/catalog/media folder.But it is not showing the image in the magento admin.Here is the screenshot of the issue.Can there be any reason for the image not saving in product in admin.enter image description here

12
  • Did you tried clearing browser's cache, or any other browser Commented Jun 12, 2014 at 5:13
  • Yes i tried clearing browser cache and also in other browser but image is not uploading.@TBIInfotech
    – Abinaya
    Commented Jun 12, 2014 at 5:15
  • Check if you have enough space at your FTP and if the limit was not exceeded. Commented Jun 12, 2014 at 5:27
  • Ok try logout and login, and check if the image is showing? Commented Jun 12, 2014 at 5:51
  • Image is saved in media/tmp/catalog/product folder.
    – Abinaya
    Commented Jun 12, 2014 at 6:32

6 Answers 6

4

Disable flash uploader magento and install the below plugin to solve the issue. The Key for connect 2.0

http://connect20.magentocommerce.com/community/Dull_Uploader
1
  • 3
    could you please give some more detailed information on this plugin Commented Jun 13, 2014 at 13:58
4

I have the same problem. The issue was with the PHP7.0.

I have such situation First

I have chosen the image, have clicked the "Upload" button. The row with the file name has become in red color.

I have debuged it and found error

Then I have fixed it quickly I have added the {} symbols and Uploading starts working

4
  • Yes, It's working Commented Oct 22, 2016 at 8:54
  • the change in code saved my life! was looking for hours until i stumbled upon this answer
    – Bart Hofma
    Commented Jan 30, 2017 at 1:43
  • @xdoctordog sorry i dont get what u r suggesting on that line . Can u plz explain it
    – inrsaurabh
    Commented Jul 11, 2017 at 11:45
  • Please, try to add braces in core Magento file, like I had shown on the screenshot.
    – xdoctordog
    Commented Aug 28, 2017 at 10:06
3

Product images are not uploaded in magento admin

  1. Make Sure u have uploaded flash player
  2. Enable GD library in the php.ini file -> ;extension=php_gd2.dll Remove ;
0

Give 777 permission to this folder : /opt/lampp/htdocs/magento/media/wysiwyg

-2

Goto FTP open Media Directory and just change name of

.htaccess to .htaccess_old

And remove the Cache

2
  • 3
    Never use this solution. You may face other issue to. Because .htaccess files are used for setting up site configuration and renaming current one will overwrite setting and a default one will be created. Commented Jan 29, 2015 at 10:49
  • 1
    When you do this, you open yourself up to people uploading php scripts into your media directory structure and being able to execute them. Congratulations for opening up a security hole that the Titanic can pass through. If you read that .htaccess file, it has specific entries to prevent execution of files out of the media folders. Commented Jul 24, 2015 at 0:00
-2

What worked for me (on an older version of Magento of 1.3.2.4) was a recursive permission of 777 of the media folder AND renaming the .htaccess to .htaccessold - I then logged out, cleared the cache, logged back in and IT WORKED!!

1
  • 3
    The removed .htaccess file had specific entries to prevent file execution out of the media folder structure. You've just enabled a security hole. Commented Jul 24, 2015 at 0:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.