6

enter image description here

Images are not displaying in magento2.3.1.

https://www.depoto.com/test-product.html

enter image description here

  1. I gave the permissions for media folder 777 already.
  2. We are not using any extension which relates to the product

I have run all the following commands, but no use.

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy
php bin/magento indexer:reindex 
php bin/magento cache:flush
12
  • As i can see, you are using porto theme, 1. make sure there is media images folder in the pub folder. 2. run this command php bin/magento setup:static-content:deploy 3. if still image not shows then run this command php bin/magento catalog:images:resize. make sure please flush cache after run this commands.Thanks Commented Aug 7, 2018 at 5:23
  • please check the updated question. I tried but no change. I enabled the cache in cache management Commented Aug 7, 2018 at 5:44
  • please check in admin there will be lazy loader setting in theme section just disable it , i think tab name some thing like website speed where is that setting Commented Aug 7, 2018 at 6:26
  • in porto setting panel Disable Lazyload for Product Images is in no Commented Aug 7, 2018 at 6:31
  • it has lazy loader see i have just copy class from porto theme demo product-image-photo default_image porto-lazyload porto-lazyload-loaded Commented Aug 7, 2018 at 6:36

2 Answers 2

0

Store -> Configuration -> Disable Lazyload for Product Images: Yes

0

You can try this solution:-

Replace “Option FollowSymLinks” with “Options +SymLinksIfOwnerMatch” in pub/media/.htaccess file and pub/.htaccess file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.