I have created a staging magento copy of live site on a sub folder, everything goes fine until now.

When I want to install module, and run magento module:status doesn't appear on the list.

The folder of module is on app/code, but nothing happens.

Any clue about this problem?


[More Info]

I'm trying to install this module https://store.plumrocket.com/twitter-facebook-login-magento2-extension.html


<?xml version="1.0"?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:Module/etc/module.xsd">
<module name="Plumrocket_SocialLoginFree" setup_version="2.2.0">
        <module name="Magento_Customer" />
        <module name="Plumrocket_Base" />


\Magento\Framework\Component\ComponentRegistrar::register( \Magento\Framework\Component\ComponentRegistrar::MODULE, 'Plumrocket_SocialLoginFree', __DIR__ );

  • What is the error that's is thrown ? Aug 6, 2018 at 19:29
  • I upload the module manually, on app/code, the names are correct and also the content. But when in console I run magento module:status , it doesn't appear on List of disabled modules, so I can't enable this
    – gaby1990
    Aug 6, 2018 at 19:38
  • Have You run the php bin/magento setup:upgrade this command. Aug 6, 2018 at 19:45
  • @Learing_Coder I've already run this command, but nothing new appears.
    – gaby1990
    Aug 7, 2018 at 11:37

1 Answer 1


Please check in your module there registration.php exist with below code with no typo:


and also module.xml etc/module.xml

  <?xml version="1.0"?>
 <config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
<module name="Namespace_Modulename" setup_version="1.9.1">

  • I've checked those files and everything is ok. I don't know what could happen. Maybe permissions on folders?
    – gaby1990
    Aug 7, 2018 at 11:39
  • @gaby1990 Can you please share your code for registration and module file in question. May be We can help you Aug 7, 2018 at 11:43
  • I edited the question to add more information. Thanks for helping me!
    – gaby1990
    Aug 7, 2018 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.