2

When cloning a site for local development I get the following error:

a:5:{i:0;s:223:"Error in file: "/Applications/apache2/htdocs/app/code/core/Mage/Cms/data/cms_setup/data-install-1.6.0.0.php" - A block identifier with the same properties already exists in the selected store.";i:1;s:1100:"#0 /Applications/apache2/htdocs/app/code/core/Mage/Core/Model/Resource/Setup.php(644): Mage::exception('Mage_Core', 'Error in file: ...')

Im using a MAMP stack. The existing database was imported and connect via local.xml.

I cant edit core. Why is this error coming up? Conflict between wanting to setup new install vs using existing db?

6
  • Can you elaborate your process please? If you really imported the core DB, this script should never be executed, because the core_resource table should already have an entry for the CMS module in the required version. Aug 6, 2018 at 17:05
  • In core resource there is an entry for 1.6.0.0.2 but the value in the error is 1.6.0.0.0. Aug 6, 2018 at 17:38
  • Ok so you did download source -> import db -> connect db in local xml -> load page? Are you sure you downloaded the exact same version as before, including patches? Also, what happens if you simply change the entry in core_resource? Aug 6, 2018 at 18:29
  • I put the sql file in mysql/bin and ran source DB_Name. When I deleted it I got a new error. Aug 6, 2018 at 18:55
  • WHen I change the identifer where it says it already exists a new one is automatically created and the same error comes back. Aug 6, 2018 at 20:02

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.