3

I just installed Magento 2.2.5 but in admin > content > page the page grid and the button are not displaying. Even in the block the same issue happens, records grid and button is not displaying. Remaining things are working well.

I checked in console but no error is displaying.

Please check the following screenshot for more details.

enter image description here

enter image description here

  • have you checked browser console logs and Magento logs? – kunj Aug 6 '18 at 7:15
  • Yes I checked the browser console as well as magento log but not getting any error. – David Coder Aug 6 '18 at 7:18
  • 2
    You've said "I just install Magento 2.2.5" but still there is clearly third party extension blurred out in admin menu .... please disable all the third party extensions, it is most probably the cause of the error. – Vivek Kumar Aug 20 '18 at 22:06
  • 1
    Yes I disable all the extension but still that is not loading I think it is some js issue – David Coder Aug 21 '18 at 5:58
  • 1
    Pages & block ui component not loaded because of third party extension have bad/wrong ui component syntax. not all M2.x extension support with M2.2.5. I've M2.x extension from some vendor, and I got the problem. so, I try to remove thats extension.. but i got the problem like this. prnt.sc/kl5j2r – Jackrose Aug 21 '18 at 10:03
0

Try Following Commands.

  1. empty var folders,

    rm -rf generated/metadata rm -rf generated/code rm -rf pub/static without .htaccess file

  2. enable back developer mode,

    php bin/magento deploy:mode:set developer

mode to the production mode and vice versa. While doing this, it truncates the var/di, var/generation, and var/view_preprocessed directories.

  1. upgrade modules,

    php bin/magento setup:upgrade

  2. compile,

    php bin/magento setup:di:compile

  3. deploy

    php bin/magento setup:static-content:deploy -f

  4. cache remove and reindex,

    php bin/magento cache:clean php bin/magento cache:flush php bin/magento indexer:reindex

0

You said you have just installed Magento. So you have to run below set of commands:

php bin/magento setup:upgrade

php bin/magento setup:static-content:deploy -f

php bin/magento indexer:reindex

php bin/magento cache:clean

Before running these commands first delete the content of following directories:

pub/static/frontend
var/view_preprocessed
0

Run below command and check folder and file permission then check

php bin/magento setup:upgrade
php bin/magento cache:clean
  • I did it already. but still not displaying. – David Coder Aug 17 '18 at 9:32
0

You need to something like this.

  1. Upload fresh magento 2.2.5 file to into current website. (Because if anything missing, then it overide)

  2. Run following command from CLI.

    php bin/magento cache:clean
    php bin/magento cache:flush
    php bin/magento indexer:reindex
    php bin/magento setup:upgrade
    php bin/magento setup:static-content:deploy -f
    
  • Yes that things I have already done. I have replaced the module-cms but still the same issue. – David Coder Aug 18 '18 at 5:01
  • I am talking about upload entire magento files, not only module-cms. – Dhiren Vasoya Aug 20 '18 at 3:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.