3

I run Magento 1.9.3.x and in the process of cleaning up old modules not in use anymore I disabled Inchoo Notes, after this I got errors... I googled help online help and was recommended to delete files and records from the database.

Now I ended up with Fatal error:

Class 'Mage_Inchoo_Notes_Helper_Data' not found in /var/www/domain.dk/public_html/app/Mage.php on line 547 showing when I enter /system_config/...

Even more weird if i disable, another module; Inchoo_FeaturedProducts.xml (true to false) the fatal error is gone and I can use /system_config/ again... but, I am using Inchoo FeaturedProducts module to display products on the frontpage... so that is not a doable solution.

Any ideas what to do here ?

Thanks.

  • check system.xml files of the all the modules which are having Inchoo as Namespace – sandip Aug 6 '18 at 1:16
  • I have 123 system.xml files... only one of them contains "inchoo"... located at \app\code\community\Inchoo\FeaturedProducts\etc – Dennis Aug 6 '18 at 2:13
  • The first few lines are: <tabs> <inchoo module="inchoo_notes"> <label>Inchoo</label> <sort_order>110</sort_order> </inchoo> </tabs> – Dennis Aug 6 '18 at 2:15
  • Replace inchoo_notes with Inchoo_FeaturedProducts – sandip Aug 6 '18 at 2:19
  • is Compilation is On ? – Pawan Aug 6 '18 at 3:24
1

Replace inchoo_notes with Inchoo_FeaturedProducts

<tabs> <inchoo module="Inchoo_FeaturedProducts"> <label>Inchoo</label> <sort_order>110</sort_order> </inchoo> </tabs>
  • Thank you so much for trying to help. I really appreciate that. – Dennis Aug 6 '18 at 3:56
  • Accept the answer by pressing right icon. Upvote the answer – sandip Aug 6 '18 at 4:17
  • I would love to - but the issue is not solved... Tried the edits... empty cache, compilation is deactivated... I manually decompiled... log out, logged in... deleted /var/cache/... still the same problem... – Dennis Aug 6 '18 at 4:18
  • 1
    I ended up outcommenting the <tabs> section - problem solved! – Dennis Aug 7 '18 at 2:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.