After I copied files for a new Theme, I was able to upgrade and deploy but when I open the main site it is throwing me

Exception #0 (RuntimeException): Class Magento\Framework\View\EntitySpecificHandlesList does not exist

When I ran compile command I'm getting the following error. This is continuation of the issue After Theme Installation Main site is down

Updated with Error Stack trace

sudo php bin/magento setup:di:compile
Compilation was started.
Interceptors generation... 4/7 [================>-----------]  57% 12 secs 164.0 MiBMiB8.0 MiB

  Class Magento\Framework\View\EntitySpecificHandlesList does not exist

Exception trace:
 () at /var/www/html/lib/internal/Magento/Framework/Code/Generator.php:115
 Magento\Framework\Code\Generator->generateClass() at /var/www/html/setup/src/Magento/Setup/Module/Di/Code/Generator.php:70
 Magento\Setup\Module\Di\Code\Generator->generateList() at /var/www/html/setup/src/Magento/Setup/Module/Di/App/Task/Operation/Interception.php:100
 Magento\Setup\Module\Di\App\Task\Operation\Interception->doOperation() at /var/www/html/setup/src/Magento/Setup/Module/Di/App/Task/Manager.php:56
 Magento\Setup\Module\Di\App\Task\Manager->process() at /var/www/html/setup/src/Magento/Setup/Console/Command/DiCompileCommand.php:187
 Magento\Setup\Console\Command\DiCompileCommand->execute() at /var/www/html/vendor/symfony/console/Symfony/Component/Console/Command/Command.php:257
 Symfony\Component\Console\Command\Command->run() at /var/www/html/vendor/symfony/console/Symfony/Component/Console/Application.php:874
 Symfony\Component\Console\Application->doRunCommand() at /var/www/html/vendor/symfony/console/Symfony/Component/Console/Application.php:195
 Symfony\Component\Console\Application->doRun() at /var/www/html/lib/internal/Magento/Framework/Console/Cli.php:96
 Magento\Framework\Console\Cli->doRun() at /var/www/html/vendor/symfony/console/Symfony/Component/Console/Application.php:126
 Symfony\Component\Console\Application->run() at /var/www/html/bin/magento:23
  • Is your theme compatible with the version of magento 2 your using? – Chris Anderson Aug 3 '18 at 16:27
  • Yes, I'm using version 2.1.6 and I'm taking the corresponding lib, app, pub folders for this version from the theme – Actung Aug 3 '18 at 16:32
  • Which deploy mode are you using - developer or production? – Vivek Kumar Aug 3 '18 at 21:37
  • Check file/folder permissions once – inrsaurabh Aug 4 '18 at 6:07
  • @VivekKumar I am using developer mode, I also tried with default mode before but still the same error – Actung Aug 6 '18 at 8:27

Class EntitySpecificHandlesList comes from version 2.2.x and doesn't exist below 2.2.x. So definitely it would be the exception.

| improve this answer | |
  • Its a bug in the theme and they are going to update with a new patch, but you are right somewhere it is calling this class from Magento 2.2.x – Actung Aug 9 '18 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.