1

I created store in admin Now i want to hit like below urls and I created folder in magento root directory 'ca' and 'fr' and 'au' folder and also put .htaccess and index.php file Now what is the next step?
'ca', 'fr', 'au' is my stores code
How can I configure store urls like below?
Please Help it's urgent!

Canada https://mywebsite.com/ca/
France https://mywebsite.com/fr/
Australia https://mywebsite.com/au/

URLS GOING to 404 error: Page not found.

0

You have to create storeviews. You must go to:

Stores -> Settings -> All Stores -> Create Storeview

Then there you can create the storeviews you desire.

You keep the store same as Default and you fill in the gaps.

Bear in mind that the code will be the one appears in the URL.

Then you will be able to make changes in the web choosing between storeviews and being able to make differences between these stores.

|improve this answer|||||
  • Before Urls working after i created ca folder for sitemap.xml for storewise after that store url going 404 so how i run url with store code – Jugal Kishor Aug 3 '18 at 12:52
  • I recommend you using storeviews instead of sitemap. I don't know how sitemap works. Or explore other solutions. – Raül Aug 3 '18 at 12:53
  • i put .htaccess file or index.php in ca folder [ca folder for canada store view] but client saying that he want sitemap.xml store wise so i create ca folder and generate sitemap.xml for canada store view after that store url going 404 Before generate sitemap ULR'S was working fine – Jugal Kishor Aug 3 '18 at 12:58
  • I don't know about sitemap. I have never used it. Sorry – Raül Aug 3 '18 at 12:59
  • I want say that store code = ca and country code folder = ca – Jugal Kishor Aug 3 '18 at 13:01
0

Follow this step. It may be helpful for you :

  • On the Admin Panel, go Stores > Settings > Configuration.
  • On the left panel, under General, select Web.
  • In the upper-left corner, choose the Store View to check the new store you added.
  • Hit OK to verify the scope switching.
  • Open the Base URLs section,
  • Clear the Use Website checkbox, that is next to the Base URL field.
  • Change the Base URL for the store.
  • Open the Secure Base URLs section below to set the store’s secure URL if needed.
  • Save Config to complete.
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.