1

Hi I am very new Magento frame work. I just installed magento 1.9.0.1 and I added the new category through catalog menu. But still its not showing the category in front end.

  1. Category is under default category
  2. Is Active -Yes
  3. Display Mode -Static Block Only

These are the setting I have done with new category. After saving this, When I go to the front end its not displaying the category. How do I make the category should appear in front end.

I followed this Tutorial for creating category.

Please help me on this.

Thanks in advance.

  • 1
    Make sure the category you created has 'Include in menu' set to yes. Also reindex everything and clear the cache. – Marius Jun 11 '14 at 9:50
  • @Marius You mean "Include in Navigation Menu", if I set to yes its appearing. Is it possible to make that categories coming as left side block ?? – svk Jun 11 '14 at 10:01
  • That's a totally different question. I think you should ask a new question explaining what you need. – Marius Jun 11 '14 at 10:02
2

Make sure you have the proper root category selected under System-->Manage Stores. In my case, the proper category "All Shows". I can select it by clicking Main Website Store and choosing "All Shows". If I choose "Default Category" as my root category instead, "All Shows" and any sub-categories of that root will not show on the navigation menu. Hope this helps.

0

Based on the comments...
You have to set the flag "Include in Navigation Menu" for a category to yes to make it appear in the top menu.

0

When you say category is under default category - does this mean it is a sub directory of this? as it needs to be in order to show (not physical below it - it needs to be within it as a sub directory)

0

http://www.acumensoftwaredesign.com/magento/magento-nav-menu-not-displaying I have the same issue and followed this link.

  • 2
    Welcome To SE. Link only answers are not the best. Please include at least parts of what is found at the end of that url in your answer. – Marius Dec 9 '14 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.