0

I have successfully logged in firebox but customer session not working in chrome browser. Can anyone help me to get the solution?

It's not localhost , am checking on linux server.

closed as off-topic by Piyush, Jai, Manashvi Birla, sv3n, Dhiren Vasoya Jul 31 '18 at 14:25

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced OR seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Piyush, Jai, Manashvi Birla, sv3n, Dhiren Vasoya
If this question can be reworded to fit the rules in the help center, please edit the question.

2

This is due to the cookie problem, not in browser but in Magento itself. In Magento, by default cookie’s lifetime is set to 3600 (1 hour). But if the end users computer time runs ahead of server’s time, cookies will not get set for magento frontend as well as backend. For example, end user’s computer time is 1 hour forward than server’s time, that means the cookie (holding user’s session id) will expire as soon as user logs in or tries to add an item.

To solve this, set cookie’s lifetime to 86400 (1 day) instead of 1 hour and everything will work as expected. You can also set cookie lifetime to 0, so that cookie will only expire when the user’s browser is closed.

Go to: Magento backend -> Sytem -> Configuration -> Web -> Session and Cookie Management

Set cookie lifetime to 86400 and save. Everything will work as expected now.

  • @RutveeSojitra:Welcome – Rv Singh Aug 1 '18 at 4:22
  • Thanks, its working for me.....:) – Anas Mansuri Oct 23 at 12:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.