1

we have a live magento 1.8 site which has been running fine until recently, where we were unable to send emails via Sparkpost - this was identified as being an issue with TSL1.0.

we have forced magento to send via TLS1.2, however, in order to do this we needed to upgrade the php version from 5.5.9 to 5.6. This has worked, and emails are sending correctly.... however, the cron tasks are not running.

I have scoured the web to try and rectify this, but cannot find the reason at all. Im inexperienced in cron setup, however through the many things I have tried, ive not got a basic understanding.

  • we have AOE Scheduler installed
  • heartbeat is not working
  • all tasks are pending - and never get run
  • cron_schedule DB table is populated with all tasks - but they are all pending, none get executed
  • I can manually run a task through AOE scheduler, and this executes fine

crontab -l shows:

* * * * * ! test -e /srv/www/delilahcosmetics.com/public_html/maintenance.flag && /bin/bash /srv/www/delilahcosmetics.com/public_html/scheduler_cron.sh --mode always
* * * * * ! test -e /srv/www/delilahcosmetics.com/public_html/maintenance.flag && /bin/bash /srv/www/delilahcosmetics.com/public_html/scheduler_cron.sh --mode default
php -v

Shows as

PHP 5.6.37-1+ubuntu14.04.1+deb.sury.org+1 (cli) 
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies

I have tried adding:

$isShellDisabled = true;

to cron.php - with no effect

despite setting the value of the system user in AOE scheduler to "www-data" - this has no effect either, and AOE scheduler seems to think this is running through "" (no system user)

cron.log shows no errors

WHAT AM I MISSING?? please help. thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.