0

I have shop with some custom product attributes - everything working find. But today I added a new custom attribute (id 163) and added to default set.

I can see dropdowns for new attribute - but after saving the product with selected value of new attribute a warning is in system.log - and after reloading product in admin selected value is not set in new attribute:

main.WARNING: Attempt to load value of nonexistent EAV attribute '163' 
                    for entity type 'Magento\Catalog\Api\Data\ProductInterface'.

I find some other threads with same error but no solution. In table catalog_product_index_eav there is value of selection saved ...

Thanks for help! Martin

1 Answer 1

0

I ran into the same issue today and I couldn't immidiately figure out the cause of it. It was happening due to two new custom attributes I created yesterday, but they weren't deleted and they were assigned to an attribute set.

What seemed to have solved the issue for me was making sure that the file permissions are right and then running php bin/magento cache:flush from the console. Now my system.log is no longer being filled with this warning.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.