0

I have Migrated website Magento 1.9.1.0 to Magento 2.2.4 successfully by Using Magento Data Migration Tool. My Old Magento Website was multi-store/website. Everything is working fine but when I am going to create an account then I am getting below errors

No such entity test with email = [email protected], websiteId = 1

I have tried to some fixes by running below command but this is already updated

SET FOREIGN_KEY_CHECKS=0;
UPDATE store SET store_id = 0 WHERE code='admin';
UPDATE store_group SET group_id = 0 WHERE name='Default';
UPDATE store_website SET website_id = 0 WHERE code='admin';
UPDATE customer_group SET customer_group_id = 0 WHERE customer_group_code='NOT LOGGED IN';
SET FOREIGN_KEY_CHECKS=1;

While I have tried to create account programatically,its creating successfully but email id is not inserting in customer_entity table while it inserting in customer_entity_varchar table.

After migrating data ,website id and store id are same for both Magento and Magento2.I am also able to create product as well as place order is also working.

Is there is any option to check which entity id is missing when save customer?

I have a lot of research but nothing found to resolve this issue. Please help me.

4
  • Did you try reindex after migration? Commented Jul 27, 2018 at 9:39
  • Yes,Many times.
    – akgola
    Commented Jul 27, 2018 at 9:57
  • @akgola may i know what tutorial you following to upgrade from Magento 1 to 2?
    – Gem
    Commented Sep 23, 2019 at 4:34
  • 1
    @Gem,I have followed tutorial devdocs.magento.com/guides/v2.3/migration/… along with stackexchange forum search.
    – akgola
    Commented Sep 23, 2019 at 6:52

1 Answer 1

1

Finally I have resolved that issue with help of Magento guy @victor-v-rad

by comparing attribute_code "email" in the eav_attribute table with Magento default and found that backend type was "varchar" after migration while it is "static" in Magento Default. After updating it is working now fine.

full discussion here:

https://github.com/magento/data-migration-tool/issues/565#issuecomment-409515576

4
  • hi @akgola, I checked in eav_attribute table, have value backend_type as static only, still i am getting error like "No such entity with customerId = [] []" Commented Nov 21, 2018 at 14:57
  • @jafarpinjar let me know more detail about issue so that I can help you.
    – akgola
    Commented Nov 22, 2018 at 7:03
  • hi @akgola, here i have posted the issue magento.stackexchange.com/questions/250848/… Commented Nov 22, 2018 at 7:09
  • did you compare all attribute(column type,name.....) from eav_attribute after migration with default magento 2.if not please compare.
    – akgola
    Commented Nov 22, 2018 at 7:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.