1

I've had this issue with my Magento 2.2.3 installation where nothing gets updated in the pub folder. So every time I re-deploy, product images don't get re-populated, and no CSS changes will go through. I've only been able to add rules by putting CSS in template files, those update just fine. I'm not sure what happened to it, it was working fine at one point.

I've tried several CLI commands including static-content:deploy of course. It sounds like it could be a folder permission issue, but when I look the pub folder has the same permissions as the app folder. Anyone else run into this issue?

  • Have you enabled production mode in Magento? – Mohit Kumar Arora Jul 25 '18 at 15:53
  • No I have not. It has been in developer mode. Does it need to be in production mode to automatically update? – bsquared Jul 25 '18 at 17:04
  • If the website is under development, there is not need for production mode. – Mohit Kumar Arora Jul 25 '18 at 17:06
0

Please use below command

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy -f
php bin/magento setup:cache:clean

Test site in private window

For permission issue review this link

  • This updates the pub folder, but it seems like I need to do this every time I want to make a CSS change – bsquared Jul 25 '18 at 14:14
0

You don't need to deploy content every time.Set your deploy mode to developer then it automatically deploy if any changes occur.

Set developer mode,first check developer mode then set.

php bin/magento deploy:mode:set show
php bin/magento deploy:mode:set developer
  • It's been in developer mode the whole time, that's why I think it might be some kind of permissions issue – bsquared Jul 26 '18 at 14:34
0

Okey, finally I got the steps by which one could fix the issue.

Kindly follow below steps,

php bin/magento cache:clean

php bin/magento cache:flush

php bin/magento deploy:mode:set developer

in app/etc/di.xml change symlink to copy if windows

fix the required.js error if occurs, see Invalid template file magento2.3.0

open admin and set symlink yes from store --> configuration --> advance --> Developer --> Template Setting --> Allow Symlinks should be YES

Remove everything(NOT .HTACESS) from pub, var, generated.

php bin/magento cache:clean

php bin/magento cache:flush

php bin/magento setup:upgrade

php bin/magento setup:static-content:deploy -f

php bin/magento setup:static-content:deploy en_AU --exclude-theme Magento/luma --exclude-theme Magento/blank -f

refresh frontend and admin

delete everything(NOT .HTACESS) from pub.

Refresh frontend and this time pub/static folder will get updated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.