0

Please advise. Thanks

After doing this:

php bin/magento maintenance:enable composer require magento/product-community-edition 2.2.5 --no-update composer update authenticate correctly for repo.magento.com

I get this error:

[u9945p7191@web0102 public_html]$ Invalid credentials for 'https://repo.magento.com/packages.json', aborting. [u9945p7191@web0102 public_html]$ https://repo.magento.com could not be fully loaded, package information was loaded from the local cache and may be out of date -bash: https://repo.magento.com: No such file or directory [u9945p7191@web0102 public_html]$ Updating dependencies (including require-dev) -bash: syntax error near unexpected token `(' [u9945p7191@web0102 public_html]$ Your requirements could not be resolved to an installable set of packages.

Problem 1 - The requested package magento/product-community-edition 2.2.5 exists as magento/product-community-edition[2.2.0, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.1.0, 2.0.8, 2.0.9, 2.1.1, 2.0.10, 2.1.2] but these are rejected by your constraint.

-2

First of all, you may use wrong key-pair for upgradation, you have to use the pair which you have used previously in installation.

I think this may be an error of proxy or firewall restriction. I had the similar one and i used the following workaround for it.

set proxy

export https_proxy='192.168.10.5:8080'
export http_proxy='192.168.10.5:8080'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.