2

I have an issue where items are not displaying in there categories, sale for example, and I am wondering if it has anything to do with the configurable product quantity which is zero, although the simple products it contains have quantities?

ss-2018-24 contains the following:
ss-2018-24-s (qty 1)
ss-2018-24-m (qty 2)
ss-2018-24-l (qty 2)

ss-2018-24 inventory has the following settings:
Manage Stock - Yes (use config settings: tick)
Enable Qty Increments - No (use config settings: tick)
Enable Qty Increments - Yes

Is the fact that the configurable product has a quantity of zero, the reason the product isn't displaying under the sale category, even though it's assigned?

Some help would be really appreciated.

2
  • Did you set configurable product is in stock to yes? Jul 24, 2018 at 9:07
  • Hi, thanks for the comment, just to confirm, stock is set to yes Jul 25, 2018 at 9:38

2 Answers 2

0

YES. It has everything to do with the configurable product quantity being set to zero while also configured to manage stock.

By default, Manage Stock is turned off for a configurable product, because the inventory is managed through each associated product. This means that you should not set manage stock to yes for the configurable product itself; only the associated simple products.

Your items are not showing up in the catalog because you have a quantity of 0 configured for a product that you are managing stock on. This results in the product not being displayed, because you have indicated there are 0 of them.

Magento Documentation: https://docs.magento.com/m1/ee/user_guide/catalog/inventory-configurable-product.html

0

when we create configurable products then after creating its associated simple products then its does not show under its respected categories so it may be the cause of not re-indexed.So re-indexed from admin then check again.

Re-indexing steps:

Go to admin System > Index Management.See below screen shot.

enter image description here

1
  • Hi, thanks for the comment, site is definitely reindexed Jul 25, 2018 at 9:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.