0

I've removed the comment from php.ini file ;extension=php_intl.dll like this extension=php_intl.dll still it's showing thatPHP Extension intl is missing.enter image description here

  • Please check my answer – Rohan Hapani Jul 19 '18 at 11:22
  • @RohanHapani brother i am using wamp on windows 10 – Subhan Sunny Jul 19 '18 at 11:30
  • Okay. I will update my answer. – Rohan Hapani Jul 19 '18 at 11:34
  • please check my answer. If it's useful then you can accept answer :) – Rohan Hapani Jul 19 '18 at 11:48
  • please read my comment there : i have tried all these three things like removing the comment from php.ini file replacing files from php{version} folder to appache folder and checking if the .dll is there in ext folder – Subhan Sunny Jul 19 '18 at 11:54
2

Execute this command if you are using ubuntu/linux :

sudo apt-get update

Then,

For php5 version :

sudo apt-get install php5-intl

For php7 version :

sudo apt-get install php7.0-intl

Restart server :

sudo service apache2 restart

For windows :

C:\wamp\bin\php\php{version}, copy all the files that looks like icu*.dll and paste them into the apache bin directory C:\wamp\bin\apache\apache{version}\bin.

Then restart all services

  • but i am using wamp on windows 10 – Subhan Sunny Jul 19 '18 at 11:29
  • did that as well still facing the same issue :/ – Subhan Sunny Jul 19 '18 at 11:50
1

Please remove extension=php_intl.dll from php.ini and restart your apache server

Try now

0

I was also having the same issue, and just now i got it solved. Please try the bellow steps to get it solved:

  • Open php.ini and remove semicolon (;) from ;extension=php_intl.dll
  • When you try to restart the apache it will through some errors, that might be because of some .dll files. Simply copy all the icu****.dll files

From

Xampp folder/php

To

Xampp folder/apache/bin

  • Still i was getting msvcp110.dll file missing error. I have downloaded this missing file from Here and put that in desired location

For windows 7 32 bit it is - C:\Windows\System32

  • Now Start Apache and it is working fine.
  • i've already done this brother still it's showing me the error plus i checked ext folder and the .dll file is also there :/ – Subhan Sunny Jul 19 '18 at 11:20
  • Please check my updated answer and let me know if not working. – Suresh Chikani Jul 19 '18 at 11:33
  • i have tried all these three things like removing the comment from php.ini file replacing files from php{version} folder to appache folder and checking if the .dll is there in ext folder – Subhan Sunny Jul 19 '18 at 12:14
  • same here its not working moved ic*.dll file to apache/bin but still not working i am working on Xampp – insoftservice Feb 16 at 8:57
0

Enable intl extension by removing comma(;) from ;extension=php_intl.dll in your php.ini file.

Then restart your server and check again.

If still issue coming then try with private window.

0

There is nothing wrong with your process of installation. you just need to restart your wamp server and repeat the installation process from first step.

0

Please open your server php.ini file after that remove comma(;) in before of extension=php_intl.dll and then restart your apache server.

Replace code like ;extension=php_intl.dll To extension=php_intl.dll

Try to setup again.It's must working for you.

0

I lost a lot of time with this problem this morning, and here's what solved it for me.

My setup: Windows 10 Pro 64-bit, using xampp 7.2 and trying to install Magento 2.3.0.

For starters, I initially tried using xampp 7.3 (xampp-windows-x64-7.3.2-0-VC15-installer.exe), but Magento would not run - it had a PHP error regarding PHP syntax. Uninstalling xampp 7.3 and installing xampp 7.2 (xampp-windows-x64-7.2.15-0-VC15-installer.exe) got past that problem, but introduced the problem in this S/O question.

TL;DR

The xampp 7.2 installation is missing a file named icudt63.dll. (The exact number might vary from xampp version to xampp version.)

I was able to find a copy of the missing file easily thanks to fossies:

https://fossies.org/windows/www/php-7.3.2-nts-Win32-VC15-x86.zip/index_tp.html

I copied the file into two places: The xampp PHP directory, and the xampp Apache\bin directory.

Restart Apache - voila! The Magento PHP extensions check now passes.

If your xampp PHP and xampp Apache\bin directories contain other icu*.dll files, and the number is not 63, look for an icudt.dll instead of the icudt63.dll I needed.

In case it helps anyone investigate their own similar issue, here are some of the steps that finally led me to this very inobvious solution:

Preconditions:

  • Obviously, uncomment the "extension=intl" line in your php.ini, as the OP noted he had already done.
  • Potential MSVCP.dll issues as addressed by others. I will only touch briefly on it here.
  • Windows path (system and user) includes correct php installation directory, and does not include any other php directories. (I had another php version I uninstalled to prevent conflicts. You might need to do the same.)

  • Observe that the problem is recorded in the Apache logs. (In the xampp window, open the Apache error log, and search for "intl".)

  • Observe that the problem is with PHP generally, not Apache specifically. (On command line, type "php" to start PHP outside the Apache / web context, and note that it still displays an error message about the "intl" extension.)
  • Install the free Microsoft "Process Monitor" utility. It's not intuitive to use, but in short, I was able to see that while the "ext_intl.dll" was being loaded, there was an error about msvcp140.dll failing to load. I temporarily copied it to the PHP directory from the C:\windows\system32 directory where it was already installed, but I'm not sure in the end if that was necessary, as later when I had everything working, I deleted the copy in the PHP directory, restarted Apache, and everything continued working. After getting past the msvcp140.dll error, I noticed in the Process Monitor log that php.exe was looking for icudt63.dll. That file did not exist on my system.
  • That's when I Googled for a copy of icudt63.dll, and easily found the copy on fossies - thanks fossies!
  • I put a copy of icudt63.dll in the PHP directory, and now I could start PHP from the command line without getting the error message about the "intl" extension.
  • However, Apache still gave the same error message.
  • I made a second copy of the icudt63.dll file, this time to the Apache\bin directory, and restarted Apache, and at last, everything worked. Huzzah!

In short, at least for the current xampp 7.2 point release, it appears that the entire problem, and much frustration and time wastage for many people, stems simply from one missing file in the installer. That is sad. But the good news, if this problem affects you, is that when you know how, you can quickly get past the issue and move on. Thanks to the various random blog posts and forum answers that helped me piece this together!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.