0

I have successfully migrated all data with data-migration-tool from Magento 1.9.1.0 to Magento 2.2.4.

After investigation Admin->Customers->All Customer ,I am getting error

    1 exception(s):
    Exception #0 (BadMethodCallException): Missing required argument $options of Magento\Eav\Model\Entity\Attribute\Source\Config.

    Exception #0 (BadMethodCallException): Missing required argument $options of Magento\Eav\Model\Entity\Attribute\Source\Config.
    #0 /var/www/html/magento2/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php(34): Magento\Framework\ObjectManager\Factory\AbstractFactory->resolveArgumentsInRuntime('Magento\\Eav\\Mod...', Array, Array

)

After a lot of Investigation I found some link that have same problems and apply these fixes in my setup but not got any success.

Please Help me.

4
  • is M1 site is multi website? Please check website id in customer table. I have same issue just becuase of website id is no exist in my m2 setup customers are not loading. Jul 18, 2018 at 9:41
  • Ok,M1 is multiwebsite,can you please let me know steps?
    – akgola
    Jul 18, 2018 at 9:55
  • What changes you have done @JalpeshPatel.?
    – akgola
    Jul 18, 2018 at 9:57
  • check my answer Jul 18, 2018 at 10:13

1 Answer 1

0

Follow the steps below:

  1. Create Website, Store and store view.

  2. Use the query below.

    UPDATE customer_entity SET website_id = 'Newwebsite id' WHERE customer_entity.entity_id = oldWebsiteId;

enter image description here

I hope this will help you.

5
  • I have checked Customer attributes in Magento these are migrated in Magento2 but I have not created customer attributes in Magento 2.Hence I have removed from DB and problem resolved now.
    – akgola
    Jul 18, 2018 at 10:13
  • @akgola okay. please add your solution in answer. Jul 18, 2018 at 10:14
  • Ok,But now I am getting issue when sign In from frontend "No such entity with email = [email protected], websiteId = 1"
    – akgola
    Jul 18, 2018 at 10:16
  • @akgola have you created new website? Jul 18, 2018 at 10:17
  • Yes ,I have created.
    – akgola
    Jul 18, 2018 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.