0

I am using custom option for image uploading . when product ordered and i gets downloadable link in order. But if you enable System -> Cofiguration -> Web -> Url options -> Add store code to urls than not able to download that image in order.its redirect me on dashboard.

Is there any permanent solution for it ? or every time when i want to download that image i need to disable this option .

Thanks

1

Rewrite the following function in

app/code/core/Mage/Catalog/Model/Product/Option/Type/File.php

to below:

From

protected function _getOptionDownloadUrl($route, $params)
{

   return Mage::getUrl($route, $params);
}

To

protected function _getOptionDownloadUrl($route, $params)
{
    $websites = Mage::app()->getWebsites();
    $code = $websites[1]->getDefaultStore()->getCode();
    $params['_store'] = $code;

    return Mage::getUrl($route, $params);
}
  • Please specify the product required option(s). I am unable to upload image. – Yogesh Jun 9 '14 at 9:21
  • Have you any idea why this stuff happen i override this class and i am unable to upload image and getting error " Please specify the product required option(s)" – Yogesh Jun 9 '14 at 9:31
  • 1
    its not work in my project otherwise its work very weell – Yogesh Jun 9 '14 at 9:38
  • Adding this code but upload image not downloading in order view.Click on the image link its give 404 error...and also disable “Add Store Code to Urls” in System -> Configuration -> General -> Web but images are not downloading – Ram Sampathi Nov 11 '16 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.