0

I tried upgrading Magento 2.1.3 to Magento 2.2.5, But I faced some errors after running composer update. Any Ideas?

Here's the error codes:

 Problem 1
- Conclusion: don't install magento/product-community-edition 2.2.5
- magento/framework 100.1.3 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.3 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.4 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.5 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.6 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.7 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.8 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.9 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.10 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.11 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.12 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.13 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.14 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.3 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.4 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.5 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.6 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.7 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.8 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.9 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.10 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.11 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.12 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.13 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.1.14 requires zendframework/zend-stdlib ~2.4.6 -> satisfiable by zendframework/zend-stdlib[2.4.11, 2.4.10, 2.4.12, 2.4.13, 2.4.6, 2.4.7, 2.4.8, 2.4.9].
- magento/framework 100.2.0-rc20 requires tedivm/jshrink ~1.1.0 -> satisfiable by tedivm/jshrink[v1.1.0].
- magento/framework 100.2.0-rc20 requires tedivm/jshrink ~1.1.0 -> satisfiable by tedivm/jshrink[v1.1.0].
- Can only install one of: zendframework/zend-stdlib[2.7.7, 2.4.10].
- Can only install one of: zendframework/zend-stdlib[2.7.7, 2.4.11].
- Can only install one of: zendframework/zend-stdlib[2.7.7, 2.4.12].
- Can only install one of: zendframework/zend-stdlib[2.7.7, 2.4.13].
- Can only install one of: zendframework/zend-stdlib[2.7.7, 2.4.6].
- Can only install one of: zendframework/zend-stdlib[2.7.7, 2.4.7].
- Can only install one of: zendframework/zend-stdlib[2.7.7, 2.4.8].
- Can only install one of: zendframework/zend-stdlib[2.7.7, 2.4.9].
- Can only install one of: zendframework/zend-stdlib[2.7.7, 2.4.11].
- Can only install one of: tedivm/jshrink[v1.3.0, v1.1.0].
- magento/product-community-edition 2.2.5 requires zendframework/zend-stdlib ^2.7.7 -> satisfiable by zendframework/zend-stdlib[2.7.7].
- magento/product-community-edition 2.2.5 requires tedivm/jshrink ~1.3.0 -> satisfiable by tedivm/jshrink[v1.3.0].
- Installation request for magento/product-community-edition 2.2.5 -> satisfiable by magento/product-community-edition[2.2.5].
- magento/data-migration-tool 2.1.3 requires magento/framework ~100.1 -> satisfiable by magento/framework[100.1.3, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.2.0-rc20, 100.1.9, 100.1.10, 100.1.11, 100.1.12, 100.1.13, 100.1.14].
- magento/data-migration-tool 2.1.3 requires magento/framework ~100.1 -> satisfiable by magento/framework[100.1.3, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.2.0-rc20, 100.1.9, 100.1.10, 100.1.11, 100.1.12, 100.1.13, 100.1.14].
- magento/data-migration-tool 2.1.3 requires magento/framework ~100.1 -> satisfiable by magento/framework[100.1.3, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.2.0-rc20, 100.1.9, 100.1.10, 100.1.11, 100.1.12, 100.1.13, 100.1.14].
- Can only install one of: magento/framework[101.0.5, 100.1.0-rc1].
- Can only install one of: magento/framework[101.0.5, 100.1.0-rc2].
- Can only install one of: magento/framework[101.0.5, 100.1.0-rc3].
- Can only install one of: magento/framework[101.0.5, 100.1.0].
- Can only install one of: magento/framework[101.0.5, 100.1.1].
- Can only install one of: magento/framework[101.0.5, 100.1.2].
- Can only install one of: magento/framework[101.0.5, 100.1.0-rc1].
- Can only install one of: magento/framework[101.0.5, 100.1.0-rc2].
- Can only install one of: magento/framework[101.0.5, 100.1.0-rc3].
- Can only install one of: magento/framework[101.0.5, 100.1.0].
- Can only install one of: magento/framework[101.0.5, 100.1.1].
- Can only install one of: magento/framework[101.0.5, 100.1.2].
- magento/product-community-edition 2.2.5 requires magento/framework 101.0.5 -> satisfiable by magento/framework[101.0.5].
- Conclusion: don't install magento/framework 101.0.5
- Installation request for magento/data-migration-tool 2.1.3 -> satisfiable by magento/data-migration-tool[2.1.3].

Here's my composer.json file

{
"name": "magento/project-community-edition",
"description": "eCommerce Platform for Growth (Community Edition)",
"type": "project",
"version": "2.1.3",
"license": [
    "OSL-3.0",
    "AFL-3.0"
],
"require": {
    "magento/product-community-edition": "2.2.5",
    "composer/composer": "@alpha",
    "magento/data-migration-tool": "2.1.3",
    "mirasvit/module-search-ultimate": "^1.0",
    "kodbruket/magento2-gtm": "^1.0",
    "magewonder/magento2-smtp": "^1.2"
},
"require-dev": {
    "phpunit/phpunit": "4.1.0",
    "squizlabs/php_codesniffer": "1.5.3",
    "phpmd/phpmd": "@stable",
    "pdepend/pdepend": "2.2.2",
    "fabpot/php-cs-fixer": "~1.2",
    "lusitanian/oauth": "~0.3 <=0.7.0",
    "sebastian/phpcpd": "2.0.0"
},
"config": {
    "use-include-path": true
},
"autoload": {
    "psr-4": {
        "Magento\\Framework\\": "lib/internal/Magento/Framework/",
        "Magento\\Setup\\": "setup/src/Magento/Setup/",
        "Magento\\": "app/code/Magento/"
    },
    "psr-0": {
        "": "app/code/"
    },
    "files": [
        "app/etc/NonComposerComponentRegistration.php"
    ]
},
"autoload-dev": {
    "psr-4": {
        "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
        "Magento\\Tools\\": "dev/tools/Magento/Tools/",
        "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
        "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
        "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
    }
},
"minimum-stability": "alpha",
"prefer-stable": true,
"repositories": {
    "0": {
        "type": "composer",
        "url": "https://repo.magento.com/"
    },
    "magento": {
        "type": "composer",
        "url": "https://repo.magento.com"
    },
    "mirasvit-ssu2": {
        "type": "composer",
        "url": "https://16715:L9IJ8A7G04@packages.mirasvit.com/"
    }
},
"extra": {
    "magento-force": "override"
}

}

1

There is a version of each data-migration-tool for each version of Magento. You have to update your data-migration-tool to 2.2.5 as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.