I followed the below link for data migration.


Once i run below command i am getting

php bin/magento migrate:data --reset < path to your config.xml > --- replaced the path for my m1 version that is


Integrity Check failed

error. Can anyone suggest please? What is the cause for this?

in config.xml i added the below code.

    <database host="host-name" name="db-name" user="user-name" password="password" />
    <database host="host-name" name="db-name" user="user-name" password="password" />

Here is the screenshot. enter image description here

  • Did you migrate setting? – Sukumar Gorai Jul 13 '18 at 12:06
  • Yes, php bin/magento migrate:settings --reset <path to your config.xml> that's shown completed. – jafar pinjar Jul 13 '18 at 12:08
  • What is the exception are you getting? – Sukumar Gorai Jul 13 '18 at 12:13
  • php -d memory_limit=10G bin/magento migrate:data -r -a path to your config.xml > Try this it should work but you will get warning and errors but still data will be migrated to your system. Afterwards you need to fix those errors and warnings one by one. – Sukumar Gorai Jul 13 '18 at 12:14
  • I tried above command with memory_limit , same again. what i got previously same error. I have attached the screenshot. – jafar pinjar Jul 13 '18 at 12:21

You need to add the documents and fields that are shown in the error message (in red) to the ignore list.

For more details on how to do this, check https://devdocs.magento.com/guides/v2.0/migration/migration-tool-internal-spec.html

  • hi @Anshu Mishra, can we migrate only customers and orders? – jafar pinjar Nov 22 '18 at 15:19
  • @jafarpinjar Yes – Anshu Mishra Nov 22 '18 at 17:02
  • I have migrated all data successfully, now i need to migrate latest orders n customers, can you provide me the steps please how to migrate only customers n order? – jafar pinjar Nov 23 '18 at 7:22
  • hi @Anshu mishra, I am getting below error. Notice: Undefined offset: 9 in vendor\magento\data-migration-tool\src\Migration\Step\Eav\Data.php on line 292 – jafar pinjar Apr 12 '19 at 9:31
  • IN which file do i need to turn off? I am migrating data from 1.9 to 2.3, ce-ce version – jafar pinjar Apr 12 '19 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.