0

I have upgraded Magento 1.9.1.1 to Magento 1.9.3.8. After this I am not able to reindex "Catalog URL Rewrites" index while all other index are working fine (I am able to index them).

I am getting error 505 error: "Request Timeout This request takes too long to process, it is timed out by the server. If it should not be timed out, please contact administrator of this web site to increase 'Connection Timeout'."

Also I am not able to get this error info in any log files. Also I have no SSH access.

I have upgraded the website in localhost and then move files only to live server today. Website is working fine but as reindexing is one of the most important step so I am not able to do this and its causing some other issue in backend.

  • How many products and categories you have? Also you need ssh details to reindex if there are more data. If you dont have then you need to create a cron which reindex all data. – Sukumar Gorai Jul 12 '18 at 14:44
  • I have solve this by truncate " core_url_rewrite " table and then quickly reindex from backend as website url structure was broken. After reindex all url structure works fine now. – Abi Sharma Jul 19 '18 at 6:49
1

This error is caused by one of the timeout settings in php or fcgi. Usually web server administrators configure these values per their needs.

You can see the exact cause in the php error log of apache/nginx (depends on what you use).

If you have access to the php.ini file which your site uses, then you can adjust the max_execution_time and max_input_time variables to something like 60 or 120 (in any case more than the current number).

This will allow the reindexing process more time to finish.

Also if your site uses FastCGI then another timeout variable might be the cause of this error and that is FcgidIOTimeout (previously know as IPCCommTimeout) - this might need adjusting as well in Apache's fcgid.conf file.

I would recommend to first try adjusting the values in php.ini and then go for the fcgid.conf if the first doesn't help.

If you don't have access to these files, you can ask your hosting provider to do this for you.

Also the best solution for your issue would be to get SSH access and do the reindex process with commands:

  • php -f shell/indexer.php reindexall - to reindex all indexes
  • php shell/indexer.php --reindex catalog_url - to reindex just the
    Catalog URL rewrite index

Shell commands are much quicker in the reindexing process than when you do it through Magento's admin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.