I've just downloaded an extension via SSH like this...

composer require magefan/module-blog

It tells me it has downloaded 100% successfully and refreshes the command line.

I then got to check that the extension is available to install like this...

php bin/magento module:status

But the module is nowhere on the list, either disabled or enabled.

I've tried this with three extensions now, and it is the same every time.

Any help would be much appreciated.

  • can you see it when you type in composer info???
    – Greg
    Jul 12, 2018 at 14:03
  • run setup upgrade, di compile and static content deploy then check. Jul 12, 2018 at 14:04
  • I have done all those, but still nothing in the enabled or disable module lists. Jul 12, 2018 at 14:19
  • Is it showing on your vendor folder? Jul 12, 2018 at 14:28
  • No it isn't, no changes to that folder today. Jul 12, 2018 at 14:38

1 Answer 1


If it's not in the vendor folder, or app/code (typically composer modules go in the vendor folder, but it can depend on the composer file), then it likely hasn't installed.

Recommended to try installing it again. You can also try clearing composer cache in case of a corrupt download composer clearcache, and trying again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.