0

I am migrating Magento 1.9.3.9 to Magento 2.2.5 and getting below error

The command I run from my Windows machine

php bin/magento migrate:data --reset vendor/magento/data-migration-tool/etc/opensource-to-opensource/1.9.3.9/config.xml

Getting error in command prompt

 [Migration\Exception]
 Invalid config filename: vendor/magento/data-migration-tool/etc/opensourc
 e-to-opensource/1.9.3.9/config.xml

EDIT

When remove below part it start process but nothing import as all are in comment or removed

<steps mode="data">
    <step title="Data Integrity Step">
        <integrity>Migration\Step\DataIntegrity\Integrity</integrity>
    </step>
    <step title="EAV Step">
        <integrity>Migration\Step\Eav\Integrity</integrity>
        <data>Migration\Step\Eav\Data</data>
        <volume>Migration\Step\Eav\Volume</volume>
    </step>
    <step title="Customer Attributes Step">
        <integrity>Migration\Step\Customer\Integrity</integrity>
        <data>Migration\Step\Customer\Data</data>
        <volume>Migration\Step\Customer\Volume</volume>
    </step>
    <step title="Map Step">
        <integrity>Migration\Step\Map\Integrity</integrity>
        <data>Migration\Step\Map\Data</data>
        <volume>Migration\Step\Map\Volume</volume>
    </step>
    <step title="Url Rewrite Step">
        <integrity>Migration\Step\UrlRewrite\Version191to2000</integrity>
        <data>Migration\Step\UrlRewrite\Version191to2000</data>
        <volume>Migration\Step\UrlRewrite\Version191to2000</volume>
    </step>
    <step title="Log Step">
        <integrity>Migration\Step\Log\Integrity</integrity>
        <data>Migration\Step\Log\Data</data>
        <volume>Migration\Step\Log\Volume</volume>
    </step>
    <step title="Ratings Step">
        <integrity>Migration\Step\Ratings\Integrity</integrity>
        <data>Migration\Step\Ratings\Data</data>
        <volume>Migration\Step\Ratings\Volume</volume>
    </step>
    <step title="ConfigurablePrices step">
        <integrity>Migration\Step\ConfigurablePrices\Integrity</integrity>
        <data>Migration\Step\ConfigurablePrices\Data</data>
        <volume>Migration\Step\ConfigurablePrices\Volume</volume>
    </step>
    <step title="OrderGrids Step">
        <integrity>Migration\Step\OrderGrids\Integrity</integrity>
        <data>Migration\Step\OrderGrids\Data</data>
        <volume>Migration\Step\OrderGrids\Volume</volume>
    </step>
    <step title="Tier Price Step">
        <integrity>Migration\Step\TierPrice\Integrity</integrity>
        <data>Migration\Step\TierPrice\Data</data>
        <volume>Migration\Step\TierPrice\Volume</volume>
    </step>
    <step title="SalesIncrement Step">
        <integrity>Migration\Step\SalesIncrement\Integrity</integrity>
        <data>Migration\Step\SalesIncrement\Data</data>
        <volume>Migration\Step\SalesIncrement\Volume</volume>
    </step>
    <step title="PostProcessing Step">
        <data>Migration\Step\PostProcessing\Data</data>
    </step>
</steps>

When Comment below part from config.xml it start reading but gives error Integrity check failed whats wrong with this part

<step title="Map Step">
        <integrity>Migration\Step\Map\Integrity</integrity>
        <data>Migration\Step\Map\Data</data>
        <volume>Migration\Step\Map\Volume</volume>
    </step>
  • By default the file name is config.xml.dist, can you confirm you have changed the filename. – Gagan Jul 12 '18 at 12:34
  • yes its config.xml only – Zaheerabbas Jul 13 '18 at 2:43
  • Can you try making it .dist again and run command with dist. I know it is the same but you can try. – Gagan Jul 13 '18 at 4:26
  • it work but nothing to migrate. – Zaheerabbas Jul 13 '18 at 4:31
  • You have put the code back which you shared above that you removed, right? – Gagan Jul 13 '18 at 5:13
2

Please give full path and try:

php bin/magento migrate:data --reset /var/www/html/{{magento2}}/vendor/magento/data-migration-tool/etc/opensource-to-opensource/{{magento1 version}}/config.xml

  • not working php bin/magento migrate:data --reset D:\wamp64\www\mage225no\vendor\magento\data-migration-tool\etc\opensource-to-opensource\1.9.3.9/config.xml – Zaheerabbas Jul 12 '18 at 12:24
  • try using forward slash: D:/wamp64/www/mage225no/vendor/magento/data-migration-tool/etc/opensource-to-opensource/1.9.3.9/config.xml – Rutvee Sojitra Jul 12 '18 at 12:26
  • already tried that – Zaheerabbas Jul 12 '18 at 12:27
1

I find answer myself.

I was trying to run a command php bin/magento migrate:data --reset D:\wamp64\www\mage225no\vendor\magento\data-migration-tool\etc\opensource-to-opensource\1.9.3.9\config.xml in development mode.

So it every time when run it shows Invalid config filename.I research and get some idea about why this happens and finally got the answer that we must run this command in default mode don't know about production mode.

BTW,Thank you everyone, who help me on this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.