1

I am trying to connect my MailChimp account to my Magento multistore. I couldn't seem to connect it using the Access Key and Magento Connect so I have downloaded the TGZ files from Magento Marketplace, unzipped them and copied the folders into my Magento store root directory, following the instructions from MailChimp (here).

I am having two issues:

  1. The following file will not copy over to my FTP: MailChimp Connect Files\skin\js\app\design\adminhtml\default\default\template\ebizmarts\mailchimp\system\config\form\field\array_dropdown.phtml

enter image description here

This is the only file that is returning an error. I have tried to upload it multiple times but I get the same error message every time. This is the only error information that's coming up on the FTP.

  1. This is the main issue: MailChimp does not appear in my Magento Configuration Settings panel and therefore doesn't look like it's connected.

I have followed all the instructions to the letter (famous last words), so I'm really confused as to why it's not connecting.

Can anyone advise?

Any help would be greatly appreciated.

Many thanks Anna

0

Can you try copying that file to your desktop, then try uploading manually into the remote directory it's trying to create? It might be because the filepath is too long for Windows to read.

Failing that, it's likely to be file/folder permissions on the server

  • Thanks! I copied and pasted the array_dropdown.phtml file to my desktop and successfully dropped it in to the right folder on the FTP. Thanks Ryan. You are a genius! – user69135 Jul 12 '18 at 12:26
  • The main issue of MailChimp not appearing in my Magento Configuration Settings panel, so it doesn't look like it's connected. – user69135 Jul 12 '18 at 12:32
  • @user69135 if any of the files are missing then that will happen - I'd suggest copying all files from a shorter filepath (e.g. move the mailchimp folder to desktop then re-upload) – Ricky Odin Matthews Jul 12 '18 at 12:47
  • Yes, I have tried reuploading everything from my desktop (to shorten the path) but it's still not connecting. How odd. All of the files are definately there now. The cach has been flushed before and after the upload. I have signed out of Magento and logged back in. It must be something blindingly simple that I'm not doing! – user69135 Jul 12 '18 at 13:15
  • 1
    You were right! While the FTP uploads should have the right permission in our server set up, some of them were incorect. This has been rectified, but still no MC showing in Magento. I have raised a ticket with eBizmarts as I've tried everything else on their forum. :) – user69135 Jul 13 '18 at 12:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.